Sign in to follow this  
Followers 0
lzamora

Getting a javascript grid on a html page

3 posts in this topic

Hi folks.

I'm trying to get a response of a grid (enable) doing a search on a intranet page.

Get this picture!

1.I´m typing and selectind some fields to build a search for documents on my intranet page

2.While im doing this, a have a hide section below this fields (i cant see while im building my search)

3.After i defined all the fields im clicking on search button.

4.After clicking on search button, a grid appears bringing the results of my search

??This grid i trying to get...is part of the same page, same form...

??Also, after that i need to move some of the info to a excel document....

Hope you guys could help me out.

thanks!

Share this post


Link to post
Share on other sites



Presumably the "grid" is an HTML table. See _IETableWriteToArray() and the other _IE* functions in the help file.

For writing it to Excel, there are _ExcelWriteSheetFromArray() and other _Excel* functions. Again, see the help file.

:mellow:


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Presumably the "grid" is an HTML table. See _IETableWriteToArray() and the other _IE* functions in the help file.

For writing it to Excel, there are _ExcelWriteSheetFromArray() and other _Excel* functions. Again, see the help file.

:mellow:

Yes, it works. Returns me info from header and standard fields, but it doesnt bring any info about the grid after the search.

Im using all variations of the same command. and below is the structure im working whit.

#include <ie.au3>

#include <Array.au3>

;~ $file = @ScriptDir & "\1.htm" ;make your script store the file localy, or point it to the open instance.

;~ $oIE = _IECreate($file,0,0) ;open the file

WinActivate ("Grupo Madagascar - Financeira")

Dim $oIE = _IEAttach ("Grupo Madagascar - Financeira")

$oTable = _IETableGetCollection ($oIE, 0)

$aTableData = _IETableWriteToArray ($oTable, True)

_ArrayDisplay($aTableData)

I need only the response that the grig was build to mensure the time that yhis search was taking.

If i had tha return that the grig was loaded i have the answer for my problems.

tks a lot!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0