Sign in to follow this  
Followers 0
Rigest

Need help with installing SCITE

13 posts in this topic

#1 ·  Posted (edited)

I really have a lot of fun with scripting in AutoIT. I want to thank all of you for the load of information on this forum!

So now I want to use one of the macro recorders. I could only find that they are in the Scite package. So I downloaded that here. I basicly downloaded everything that I could find and installed it all. So now I have an Scite.exe file that opens an sort of notepad/autoit thing.

Alt+F7 - Run VoSs2o0o's AutoItMacroGenerator ...Another recorder for script.

But when I press alt+f7 nothing happend :< neither in AutoIT. Then I asked a friend of mine to look at it (he has a lot more computer experience), but he didn't get it either. I'm feeling really stupid because it probably is really easy, but the documentation on the site doesn't explain how I should install it. If anyone would help me I would be really gratefull! Thanks in advanche.

P.s. sorry for any grammar or spelling errors, English isn't my first language.

Edited by Rigest

Share this post


Link to post
Share on other sites



Do you have an AutoIt file open in SciTE? You have to set the language to AutoIt for the menu items to show up.

I have, but all the menu options are working except language. When I click it I see it being clicked, but there won't appear any options to click :s

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Open a known au3 script in SciTE. Do you see the menu then? It should look like this:

Thanks for your quick reply Volly. I don't have the same menu options as you do, so I guess I didn't installed it correct. My menu looks like this

Posted Image

Edited by Rigest

Share this post


Link to post
Share on other sites

That is the weirdest menu I've ever seen. I think you uploaded the wrong pic.

Haha, my bad, I've editted the correct picture.

Share this post


Link to post
Share on other sites

With SciTE active, hold down the shift key and press F12. After you do that, look at the tools menu again.

What do you mean with SciTE active? That I have it open and I can work in it? That doesn't seem to do anything, no differences in the menu.

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Rigest.

In order for the AutoIt special menus to appear you need a saved .au3 file open in SciTE. Try that and you should get a menu like Volly showed above. :mellow:

M23

Edit: Tags went funny.

Edited by Melba23

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Rigest.

In order for the AutoIt special menus to appear you need a saved .au3 file open in SciTE. Try that and you should get a menu like Volly showed above. :mellow:

M23

Edit: Tags went funny.

Thank you Melba23, but I already used a saved .au3 file in the above screenshot. Thanks anyway.

Share this post


Link to post
Share on other sites

Any other suggestions? I downloaded Scite again en reinstalled it, but it didn't change. Isn't it possible to download a standalone version of the macro recorder?

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

That screen you posted still doesn't look correct.

How have you installed the SciTE4AutoIt3 package? (installer or Zip file?)

What does the Help/About screen tell you exactly?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0