Sign in to follow this  
Followers 0
kiboost

Scite, tools/compile in x64 by default ?

5 posts in this topic

Hi, all is in the title, how to set scite to compile by default into x64 ? I've checked preferences options and such and can't find it.


Win7 pro x64. scripts compiled to x64. - Autoit v3.3.6.1 | Scite 1.79

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

kiboost,

If your want to select "Use X64 version of AutoIt3/Aut2Exe" in SciTE > Tools > Compile.

Add this AutoIt3Wrapper.ini file to the AutoIT3Wrapper folder located in your SciTE folder.

Make sure you name the file: AutoIt3Wrapper.ini

(Important Note: Save a backup of your current ini file in the AutoIT3Wrapper folder if there is one.)

I added Usex64=1 around line 15.

' This INI sets the Defaults for AutoIt3Wrapper which can be overridden by the Compiler Directives
' Use 1 for Yes and 0 for No on options like Allow_Decompile,UseUPX and UseAnsi
' See documentation for an explanation on purpose of the fields and their values

' AutoIt section for aut2exe and AutoIt3 
[Autoit]
aut2exe=
Icon=
OutfileType=
Compression=
PassPhrase=
Allow_Decompile=
UseUpx=
UseAnsi=
Usex64=1

' Resource update section
[Res]
Language=
Comment=
Description=
Fileversion=
LegalCopyright=
Field1Name=
Field1Value=
Field2Name=
Field2Value=

[Other]
Run_AU3Check=
AU3Check_Stop_OnWarning=
AU3Check_Parameter=
Run_Before=
Run_After=

[Config]
ResHackerPath=
RCExePath=

jfcby

Edited by jfcby
1 person likes this

Determined -- Devoted -- Delivered Make your mind up -- to seriously apply yourself -- accomplishing the desired results. **** A soft answer turneth away wrath: but grievous words stir up anger. Proverbs 15:1 KJB ****

Share this post


Link to post
Share on other sites

Can't get it to work.

I've tested on xp 32, compiling manually to x64 works (error at execution).

I've tried different options/wrap options.

Anyway I have no *Wrapper folder in any of my autoit3 installation.

scite version : Version 1.79 - Apr 16 2010


Win7 pro x64. scripts compiled to x64. - Autoit v3.3.6.1 | Scite 1.79

Share this post


Link to post
Share on other sites

If I remember correctly when you install AutoIt from the exe file only a cut down version of SciTE in installed with it. You will need to go here and get the full version of SciTE and follow the instructions when installing it.

jfc14


Determined -- Devoted -- Delivered Make your mind up -- to seriously apply yourself -- accomplishing the desired results. **** A soft answer turneth away wrath: but grievous words stir up anger. Proverbs 15:1 KJB ****

Share this post


Link to post
Share on other sites

The default compiler is determined when you install AutoIt3 on your x64 system.

You indeed need to install the full SciTE4AutoIt3 for any of the directives or INI to work as that is for the AutoIt3Wrapper script.

Jos :blink:


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0