Sign in to follow this  
Followers 0
madasraka

Need help with my script

5 posts in this topic

A while ago i've made this thing called Unreal compressor.

What it does is it utilizes game executable to compress game files into format that can be uploaded to HTTP servers from which they are hosted and giving connected clients better downloading speed so they can joing the server much faster

REDIRECT it whats it called.

SO anyway.

Games are called UT2004 and UT3

UT3 code works perfect, but UT2004 even having the exact same code (different var names) the file that is being executed has some issues.

For example

UT3

Final command passed to ut3.com is C:\game folder\ut3.com compress "file 1" "file 2" etc

UT20040

Final command passed to ucc.exe is C:\game folder\ucc.exe compress "file 1" "file 2" etc

UT3 works pefectly but UT2004 or ucc.exe has issues. It doesnt like to be in a directory that has spaces in name, so C:\game folder\ucc.exe will not work unless its C:\gamefolder\ucc.exe.

I tried everything i could think off. I tried wrapping C:\game folder\ucc.exe with quotes "C:\game folder\ucc.exe" but its not working.

I tried wrapping whole thing with quotes but still no luck.

I even tried to generate filename.bat and execute it and its still not working.

Can someone look into my code and see how can i work around this.

Maybe i should execute compress command for each file individually ? IF so wouldn't that slow it down way to much ?

but even so whole generated command line cannot be longer then 1001 characters anyway.

Please if you guys have time to look that would be great.

Unreal Compressor.au3 needs sounds, i hope you can bypass this :blink:

Thanks for reading my post.

Unreal Compressor.au3

CompressUT3Function.au3

CompressUT2004Function.au3

Share this post


Link to post
Share on other sites



Try

C:\"game folder"\ucc.exe

Share this post


Link to post
Share on other sites

that looks kinda stupid but it might just work.

Hell ill try it as soon as i get back from work

Thanks mate !!

Share this post


Link to post
Share on other sites

Commandline parameters don't like it when there are spaces in between the file path since it treats every space as a delimiter that separates one parameter from the next one.

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Thats exactly what am trying to figure out how to fix

CMD understand qhotes if path has name spaceses and so does UCC.exe whhat ever comes after compress command, but even if command such as:

"D:\UT2 004\System\ucc.exe" compress "D:\UT 2004\Animations\2K4_NvidiaIntro.ukx"

is executed from file.bat its still not working unless its:

"D:\UT2004\System\ucc.exe" compress "D:\UT2004\Animations\2K4_NvidiaIntro.ukx"

I tried

D:\"UT2 004"\System\ucc.exe compress "D:\UT 2004\Animations\2K4_NvidiaIntro.ukx"

"D:\UT2 004\System"\ucc.exe compress "D:\UT 2004\Animations\2K4_NvidiaIntro.ukx"

"D:\UT2 004"\System\ucc.exe compress "D:\UT 2004\Animations\2K4_NvidiaIntro.ukx"

"D:\UT 2004\System\ucc.exe" "compress "D:\UT 2004\Animations\2K4_NvidiaIntro.ukx""

anything i can think of and nothing works. Hell it works with everything else but this ucc.exe

If by looking at my attached "CompressUT2004Function.au3" is it possible to instead of having all selected files to run as one line of command run then if not one oafter another but maybe having a number of threads somehow ?

Thanks for replies guys.

I hope i learn something from all this.

Edited by madasraka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0