Jump to content
Sign in to follow this  
Andreik

_GUICtrlRichEdit_Create

Recommended Posts

Andreik

I have a strange problem when I use this function on my computer x64. If I use this function after I close the script, AutoIt.exe process don't dissaper from Task Manager list, and my CPU usage for the process is about 50%. If I use a normal edit control this problem disappear. Have anyone this problem on x64? or know what should be the reason?

This is the line in my script where I use this function:

_GUICtrlRichEdit_Create($MAIN,"",10,85,680,455)

When the words fail... music speaks

Share this post


Link to post
Share on other sites
seandisanti

_GUICtrlRichEdit_Create($MAIN,"",10,85,680,455)

it would probably be easier to diagnose with a little more context... and what do you mean you use it after you close the script? showing the full code (or atleast enough to know what you mean by closing your script) with both edit controls would probably get a pretty quick answer...

Share this post


Link to post
Share on other sites
Andreik

Isn't any complicated script, just a gui with 2 labels and this rich edit control.

and what do you mean you use it after you close the script?

I mean, if I click on close button from my GUI, the process will not dissapear from task manager list, even if script is terminated. This happens only when I use rich edit control.

When the words fail... music speaks

Share this post


Link to post
Share on other sites
Andreik

Yes, this was the problem. My script exits before to call destroy function for rich edit.


When the words fail... music speaks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.