Sign in to follow this  
Followers 0
Tyranlol

Weird _INetSmtpMail Error

1 post in this topic

Hai

I'm using a program that writes a log file each day and sets a registry with the date of the log file, then i get my _INetSmtpMail() script to send that log file. This works perfectly when i run the script manually, but if i then use registry to start it whenever windows starts, or place it in the Startup folder it pulls out a "Error Code:1 Description:0"

I've also tried to make a 2 mins sleep before the script starts, still no result

UDF Settings:

sleep(36000)
$attachment1=RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\KL\log","Date")
$attachment2=$attachment1 & ".htm"
$SmtpServer = "smtp.gmail.com"
$FromName = "Tyranlol"
$FromAddress = "MyGmail@gmail.com"
$ToAddress = "MyGmailTwo@gmail.com"
$Subject = "Hai Autoit Forum"
$Body = ""
$AttachFiles = $attachment2
Consolewrite($AttachFiles & @CRLF)
$CcAddress = "CCadress1@test.com"
$BccAddress = "BCCadress1@test.com"
$Importance = "Normal"
$Username = "MyGmail@gmail.com"
$Password = "MyPassWord"
$IPPort =465
$ssl =1

How my other script that writes the log file runs my _INetSmtpMail() mailer

Run("mail.exe")

Any ideas? thanks in advance


[u]Only by Attempting the Impossible You Can Earn the Remarkable[/u]

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0