Sign in to follow this  
Followers 0
ty2d

Problem with @ProgramFilesDir

7 posts in this topic

I have a problem with the macro @ProgramFilesDir and would like to know if this is some sort of known problem or if I'm doing something wrong.

When I use the macro @ProgramFilesDir under Windows 7 x64 uncompiled the result is C:\Program Files, after compiling this the result is C:\Program Files (x86). I get the same result when trying this from a network share.

Can anybody explain this to me?

Share this post


Link to post
Share on other sites



When you install AutoIt3 on a 64 bits Windows, you are offered the option

to "Use X64 tools by default" (or something like that, forgot the exact wording)

If you select this, your uncompiled code will run as 64 bits.

hope that helps,

whim

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

If you want to use x86 then you need to compile it as x86 by adding this line to your script:

#AutoIt3Wrapper_UseX64=n

Otherwise use:

#AutoIt3Wrapper_UseX64=y

Br,

UEZ

Edited by UEZ

Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

Hi,

thank you for your response.

Maybe I wasn't clear enough. I would asume that the result for @ProgramFilesDir should be in both cases C:\Program Files or C:\Program Files (x86) but not depending on compiled (C:\Program Files (x86) or not compiled (C:\Program Files).

I hope I could clarify what I'm meaning.

Share this post


Link to post
Share on other sites

Read this to get an overview how redirection is working on x64 OS: http://msdn.microsoft.com/en-us/library/aa384249%28v=VS.85%29.aspx

Br,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

Hi,

thank you for your response.

Maybe I wasn't clear enough. I would asume that the result for @ProgramFilesDir should be in both cases C:\Program Files or C:\Program Files (x86) but not depending on compiled (C:\Program Files (x86) or not compiled (C:\Program Files).

I hope I could clarify what I'm meaning.

I think it was clear to begin with and the answer holds.

There are two versions of the AutoIt interpeter. A 32 and a 64 bit version. Both can be used for scripts run from SciTE, or included in a standalone executable.

You are likely using the 64 bit version to run from SciTE, but the 32 bit version to compile your scripts with, resulting in different behavior when it comes to specific functions.

Share this post


Link to post
Share on other sites

Now I got (understood) it, thank you all for your help. Seems that I was left out in the dark yesterday ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0