Sign in to follow this  
Followers 0
Spiff59

Nevermind: _GUIRichEdit commands and \factoidname

2 posts in this topic

#1 ·  Posted (edited)

When I generate RTF data using any of the functions from the GUIRichEdit.au3 include, an input line of "Patient Name: SMITH, TROY" results in an output of nifty stuff like this:

\par Patient Name: SMITH, {\*\xmlopen\xmlns2{\factoidname place}}{\*\xmlopen\xmlns2{\factoidname City}}TROY{\*\xmlclose}{\*\xmlclose}

I'm guessing it wants to setup a link to enlighten me on the history of the ancient Greek city of Troy, or maybe show me a map of Troy, New York?

Anyone ran across this \factoidname stuff when using our RTF functions?

Shouldn't this option be off by default?

Edit: Dummy me. Pardon. This code is inserted only after the doc has been opened once in Word. It's an AutoCorrect option within Word that I needed to disable...

Edited by Spiff59

Share this post


Link to post
Share on other sites



If you should want to change that for a RichEdit, it would be an EM_SETEDITSTYLE message to set the style with SES_CTFALLOWSMARTTAG cleared.

;)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0