Jump to content
Sign in to follow this  
PerryRaptor

How to Complete a Radial and press the Next Button

Recommended Posts

Still, I have not found a solution to un-check the "launch the application" feature in the install. See attached file.

I've tried ControlClick(), ControlCommand(), and ControlDisable()...Nothing works!

Here is the Au3Info for the control...

Press CTRL-ALT-F to pause the display.

>>>>>>>>>>>> Window Details <<<<<<<<<<<<<
Title:  ICS Viewer 6.0 Setup
Class:  #32770
Size:   X: 148  Y: 111  W: 504  H: 379

>>>>>>>>>>> Mouse Details <<<<<<<<<<<
Screen: X: 347  Y: 289
Cursor ID:  2

>>>>>>>>>>> Pixel Color Under Mouse <<<<<<<<<<<
RGB:    Hex: 0xFFFFFF   Dec: 16777215

>>>>>>>>>>> Control Under Mouse <<<<<<<<<<<
Size:       X: 176  Y: 150  W: 297  H: 26
Control ID: 502
ClassNameNN:    Button2
Text:       Launch the application
Style:      0x50010003
ExStyle:        0x00000004

>>>>>>>>>>> Status Bar Text <<<<<<<<<<<


>>>>>>>>>>> Visible Window Text <<<<<<<<<<<
View the readme file
Launch the application
< &Back
Finish
Cancel
Installation complete.

Setup has successfully installed the ICS Viewer 6.0.
InstallShield Wizard Complete

>>>>>>>>>>> Hidden Window Text <<<<<<<<<<<

Share this post


Link to post
Share on other sites

ControlCommand("ICS Viewer 6.0 Setup", "", "Button2", "uncheck")

That should do it. To check a box, use check instead of uncheck

Share this post


Link to post
Share on other sites

ControlCommand("ICS Viewer 6.0 Setup", " ", "Button2", "uncheck") was my first choice and no, it didn't work.

I think it has something to do with *.exe file changes during the install; however, the Windows Title is the same and so does the Class#. I'm thinking about trying to detect the *.exe file change and reset the focus.

Share this post


Link to post
Share on other sites

Send("{TAB}") nor MouseClick() work either.

<{POST_SNAPBACK}>

I had a similar problem and had really work HARD!!!!! to get around it, so maybe this can help you

first you need the actual control ID information from AU3info.exe (really great)

then try to set focus on the GUI with *******************

While 1

$func1 = ControlCommand("ICS Viewer 6.0 Setup", "", 1, "IsEnabled", "")

If $func1 = 1 Then ExitLoop

If $func1 = 0 Then

Sleep(200)

EndIf

WEnd

and or ****************************

ControlFocus("ICS Viewer 6.0 Setup", "", 1)

When i was able to get the focus i used this to find caret position

for $x= 1 to 3

Send("{TAB}")

Next

and or ***********************

for $x= 1 to 3

Send("{DOWN}") ;>>>>> this worked with checkboxes

Next

With these i found the location but.... it still would not accept an "ENTER" command (for you maybe uncheck or space or??)

so i used this to find the caret location

$a = _CaretPos()

If Not @error Then

Sleep(200)

MouseClick("left", $a[0], $a[1]) ;>>>> click the position

EndIf

with the funtion (from help file) of ***************

; More reliable method to get caret coords in MDI text editors.

Func _CaretPos()

Local $x_adjust = 25 ; 5

Local $y_adjust = 25 ;40

Opt("CaretCoordMode", 0) ;relative mode

Local $c = WinGetCaretPos() ;relative caret coords

Local $w = WinGetPos("") ;window's coords

Local $f = ControlGetFocus("","") ;text region "handle"

Local $e = ControlGetPos("", "", $f) ;text region coords

Local $t[2]

If IsArray($c) and IsArray($w) and IsArray($e) Then

$t[0] = $c[0] + $w[0] + $e[0] + $x_adjust

$t[1] = $c[1] + $w[1] + $e[1] + $y_adjust

Return $t ;absolute screen coords of caret cursor

Else

SetError(1)

EndIf

EndFunc

That was alot of work.... but there was no other way

Hope it helps you too!

good luck

Edited by Valuater

NEWHeader1.png

Share this post


Link to post
Share on other sites

Still working this issue...AU3Info show the checkbox as a button; however, sending a click to it doesn't make it uncheck. I noticed that there is a Style = 0x50010003 and an ExStyle = 0x00000004. I'm wondering if these are the reason.

I can click on the checkbox or the text during a normal install as well as the Finish button...For some reason unknown to me I cannot complete these actions via script.

It's late, I'll try your ideas in the morning.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...