Jump to content
Sign in to follow this  
Lord_Doominik

problem with childguis

Recommended Posts

i have 1 maingui and a child, gui... the maingui got a background and the childgui should be over the maingui, but it still not works... the childgui is under the maingui, and the picture in the childgui isnt transparent, too...

$mainGUI = GuiCreate("Spacewar", 800, 600,(@DesktopWidth-800)/2, (@DesktopHeight-600)/2)

;Graphics
$Background = GuiCtrlCreatePic("Grafiken\bg.bmp", 0, 0, 800, 600)
GUICtrlSetState($Background, $GUI_DISABLE)

GUICreate()

...

$LayerGUI = GUICreate("", 800, 600, 0, 0, $WS_CHILD, $WS_EX_LAYERED, $mainGUI)
    
$Raumschiff = GUICtrlCreatePic("Grafiken\Raumschiffe\Raumschiff.gif", (800-32)/2, 500, 32, 32)
    
GUISetState()

hope someone can help me...

Share this post


Link to post
Share on other sites

GUICtrlCreatePic("Grafiken\Raumschiffe\Raumschiff.gif", (800-32)/2, 500, 32, 32,$WS_EX_TRANSPARENT)

For transparent picture.

Edit: Actually I don't know.

Edited by Burrup

qq

Share this post


Link to post
Share on other sites

this dnt works... tryed it already... then the picture disappears completely and not onyl the set transparent color...

and i need help too with the problem, that the childwindow isnt OVER the maingui... :(

Share this post


Link to post
Share on other sites

dont works...

for my first question i have an answer... i need to make the maingui a child of the layergui...

but now i need the transparence...

Edited by Lord_Doominik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...