Jump to content
Sign in to follow this  

ControTreeView "Select" command not working

Recommended Posts


I've been trying to select an item within my application, and it doesn't seem to work. All of the other ControlTreeView commands work fine, but Select is not. Below is my script (pretty simple), and the msgbox returns: "$exists=1 $text=Accessories $select=1" Any ideas?



#Include <GuiTreeView.au3>



$exists = ControlTreeView ($Main_Title, "", "[CLASS:WindowsForms10.SysTreeView32.app.0.2e0c681; INSTANCE:1]", "Exists", "Main|Accessories")

$text = ControlTreeView ($Main_Title, "", "[CLASS:WindowsForms10.SysTreeView32.app.0.2e0c681; INSTANCE:1]", "GetText", "Main|Accessories")

$select = ControlTreeView ($Main_Title, "", "[CLASS:WindowsForms10.SysTreeView32.app.0.2e0c681; INSTANCE:1]", "Select", "Main|Accessories")

MsgBox(0, "Test", "$exists=" & $exists & " $text=" & $text & " $select=" & $select)

Share this post

Link to post
Share on other sites

Since this is not an AutoIt control, you might have better luck with the _GuiCtrlTreeView_* UDF functions like _GUICtrlTreeView_FindItemEx() and _GUICtrlTreeView_SelectItem().


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.