Jump to content
Sign in to follow this  
iamtheky

GDI+ behavior in WINpe

Recommended Posts

iamtheky

I am using setpixel to draw (randomly) objects around the ghost window in WINpe. On our systems with 4GB of RAM it works beautifully, however on systems with 2 gigs it does nothing.

I had issues with other fun things (video, music, flash) blowing up the entire load (mostly out of mem exception errors, a couple locked up completely) if there was not enough RAM. It seems GDI just ignores either my call or is fire and forget and doesnt care that there is not enough memory, and the ghosting proceeds normally without the visuals surrounding.

Can anyone confirm/deny that the behaviors I am seeing are not just coincidental.


,-. .--. ________ .-. .-. ,---. ,-. .-. .-. .-.
|(| / /\ \ |\ /| |__ __||| | | || .-' | |/ / \ \_/ )/
(_) / /__\ \ |(\ / | )| | | `-' | | `-. | | / __ \ (_)
| | | __ | (_)\/ | (_) | | .-. | | .-' | | \ |__| ) (
| | | | |)| | \ / | | | | | |)| | `--. | |) \ | |
`-' |_| (_) | |\/| | `-' /( (_)/( __.' |((_)-' /(_|
'-' '-' (__) (__) (_) (__)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.