Sign in to follow this  
Followers 0
redndahead

Udf Selector

5 posts in this topic

Well finally done with my UDF Selector. It should work so that if you can easily find a UDF. It is pretty self explanatory on how it works, but if you need any help feel free to post. Tell me if you find any bugs or if I could describe things better on the form.

Get it here: UDF Selector

The source is in the zip plus all the UDF's included with AutoIT 3.0.94

Pls tell me if you like it or what I can change.

Thanks :whistle:

red

Share this post


Link to post
Share on other sites



Very nice work!!! B)

Now the nitpicks: :angry:

1) I notice that buttons work in the EXE but not the AU3 version. Bug/feature?

2) Maybe the "Copy UDF" button should be called "Copy UDFs" since it copies all the functions in the list.

3) It's possible to crash (or sometimes hang) the program:

- Click "Import UDF" button

- 'X' the window when it appears

- quickly 'X' the main window

RunWait(@comspec & " /c dir /b *.au3 > c:\folderoutput.txt",@ScriptDir & "\" & $CatName,@SW_HIDE)

Error: Unable to execute the external program.

The directory name is invalid.

I'm quite impressed with the GUI :whistle:

I nomiate this program for inclusion with the AutoIt installer (along with AutoSense and JdeB's "Tidy" script).


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

1) I notice that buttons work in the EXE but not the AU3 version. Bug/feature?

Gui can't rerun the script in the au3 mode. So it has to be compiled. :angry:

2) Maybe the "Copy UDF" button should be called "Copy UDFs" since it copies all the functions in the list.

Doable. Will do. B)

3) It's possible to crash (or sometimes hang) the program:

- Click "Import UDF" button

- 'X' the window when it appears

- quickly 'X' the main window

I think I can take care of this by changing the runerrorsfatal option. Thanks!!

Thanks for the compliments. I have a bug I am working on.

1) Importing multiple scripts. Won't default a selection.

Hope to get it soon but it sometimes works and sometimes doesn't. :whistle:

red

Share this post


Link to post
Share on other sites

Alright all bugs that I know are fixed. New version uploaded. Date 2/28/04

  • Fixed some text
  • Fixed problem with adding multiple UDF's
  • Fixed Problem switching categories if previous category had no UDF's
  • Fixed fatal error if closed quickly
Got anymore bugs? Any comments?

Nigh nigh time. :whistle:

red

Share this post


Link to post
Share on other sites

I will make with au3guiXP by later tonight. Shouldn't take me longer than 10 minutes, but my wife has a list of work for me to do. :whistle:

red

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0