Sign in to follow this  
Followers 0
Distrance

Problems with AU3Record, Scite and saving scrips.

14 posts in this topic

#1 ·  Posted (edited)

Sorry about my first thread, I was getting really frustrated and google was getting me nowhere, as if I was alone with the problem.

The start menu still claims that ScriptWriter does not exist on my computer, but I found Au3Recorder from the Extras folder. However, when running SciTE and using the Tools menu .. There is like, nothing there at all. No recorder button or anything, like all guides claim that there would. The alt+f6 combo or whatever it was doesn't launch the recorder either.

Now as for recording, if I start it up manually from the Extras menu while SciTE is open and record something, nothing appears on SciTE to the new project. Additionally, when I try to save the recorded script in the Recorder ... What happens is that either the filename doesn't come up as I wrote it .. For example, if I wrote '' test '' .. The file name could be a number or single letter. The other option that happens more often is that even though it says the script is saved, nothing happens at all. Absolutely no file appears on my desktop. Then, if I try to save it again to the desktop, it claims the file is already there and do I want to overwrite ( even if I chose different filename ), and again if I overwrite, nothing appears on my desktop.

Also the script doesn't work as intended, and I don't know why. The script would go something like this : ffffffffffffdddddddddddssssssssssaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

And then repeat over again, but it cuts off after the sssssss and never does the aaaa .. Neither it does repeat the script in infinite loop.

The recorder I use is the 32 bit version by the way, the alternative doesn't work.. complains something about DLL hook .. or something.

This is getting really frustrating again D:. I managed to find alternative for AutoIt, but it wasn't freeware so I'd rather not use it if I just could get this working properly.

Any ideas ? And don't suggest reinstall, have done it like zillion times and it does not work >.<

Edited by Distrance

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Sorry about my first thread, I was getting really frustrated and google was getting me nowhere, as if I was alone with the problem.

The start menu still claims that ScriptWriter does not exist on my computer, but I found Au3Recorder from the Extras folder. However, when running SciTE and using the Tools menu .. There is like, nothing there at all. No recorder button or anything, like all guides claim that there would. The alt+f6 combo or whatever it was doesn't launch the recorder either.

Now as for recording, if I start it up manually from the Extras menu while SciTE is open and record something, nothing appears on SciTE to the new project. Additionally, when I try to save the recorded script in the Recorder ... What happens is that either the filename doesn't come up as I wrote it .. For example, if I wrote '' test '' .. The file name could be a number or single letter. The other option that happens more often is that even though it says the script is saved, nothing happens at all. Absolutely no file appears on my desktop. Then, if I try to save it again to the desktop, it claims the file is already there and do I want to overwrite ( even if I chose different filename ), and again if I overwrite, nothing appears on my desktop.

Also the script doesn't work as intended, and I don't know why. The script would go something like this : ffffffffffffdddddddddddssssssssssaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

And then repeat over again, but it cuts off after the sssssss and never does the aaaa .. Neither it does repeat the script in infinite loop.

The recorder I use is the 32 bit version by the way, the alternative doesn't work.. complains something about DLL hook .. or something.

This is getting really frustrating again D:. I managed to find alternative for AutoIt, but it wasn't freeware so I'd rather not use it if I just could get this working properly.

Any ideas ? And don't suggest reinstall, have done it like zillion times and it does not work >.<

Have you currently installed This Version(Scite4autoit3.exe) of autoit and not the BASE installation which doesn't have the tools?

Also, autoit doesn't allow me to use the tools if my file isn't saved, IN SOME CASES.

Edited by Newb

I'm a compulsive poster. When I post something, come to read it at least 5 minutes later after the posting, because I will edit it. I edited even this signature a few minutes later after I wrote it.

Share this post


Link to post
Share on other sites

Sorry about my first thread, I was getting really frustrated and google was getting me nowhere, as if I was alone with the problem.

OK.

The start menu still claims that ScriptWriter does not exist on my computer, but I found Au3Recorder from the Extras folder.

Right.

However, when running SciTE and using the Tools menu .. There is like, nothing there at all. No recorder button or anything, like all guides claim that there would. The alt+f6 combo or whatever it was doesn't launch the recorder either.

You need to be in a au3 script to see au3 script. Remember that SciTE is a universal editor.

Now as for recording, if I start it up manually from the Extras menu while SciTE is open and record something, nothing appears on SciTE to the new project. Additionally, when I try to save the recorded script in the Recorder ... What happens is that either the filename doesn't come up as I wrote it .. For example, if I wrote '' test '' .. The file name could be a number or single letter. The other option that happens more often is that even though it says the script is saved, nothing happens at all. Absolutely no file appears on my desktop. Then, if I try to save it again to the desktop, it claims the file is already there and do I want to overwrite ( even if I chose different filename ), and again if I overwrite, nothing appears on my desktop.

Also the script doesn't work as intended, and I don't know why. The script would go something like this : ffffffffffffdddddddddddssssssssssaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

And then repeat over again, but it cuts off after the sssssss and never does the aaaa .. Neither it does repeat the script in infinite loop.

The recorder I use is the 32 bit version by the way, the alternative doesn't work.. complains something about DLL hook .. or something.

This is getting really frustrating again D:. I managed to find alternative for AutoIt, but it wasn't freeware so I'd rather not use it if I just could get this working properly.

Any ideas ? And don't suggest reinstall, have done it like zillion times and it does not work >.<

Real men don't use recorders, they write their own code. That works.

Have you currently installed This Version(Scite4autoit3.exe) of autoit and not the BASE installation which doesn't have the tools?

Also, autoit doesn't allow me to use the tools if my file isn't saved, IN SOME CASES.

In ALL CASES.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

In ALL CASES.

Instead of acting smartass, try things, then come back to the forum.

Posted Image

@ Distrance:

And having an unsaved file, means the tool menu won't show those tools at all in the menu, when the bug comes.

Edited by Newb

I'm a compulsive poster. When I post something, come to read it at least 5 minutes later after the posting, because I will edit it. I edited even this signature a few minutes later after I wrote it.

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Instead of acting smartass, try things, then come back to the forum.

no need to react like this, AdmiralAlkex is right that you always have to have a file saved as ????.au3 before the specific AutoIt3 tools will work.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Newb,

Please do try to be a little more polite. :)

You need an .au3 file open in SciTE for the tools to appear. So if you have not saved your file at least once then the tools are not visible. Once the file has been saved and named as a .au3 file the tools are available even if you subsequently modify the file - as you show in your image. And a good thing too or they would not be a great deal of use! :idiot:

M23

Edit: Ah, I see Jos was quicker! ;)

Edited by Melba23

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

The problem still remains with the recorder. Surely the recorder would not exist if the program was meant for '' real men '' who make their own code. I'm not able to do that and neither am I interested in practicing something that could take months to learn properly.

Now as for recording, I saved the project and the tools menu came visible so thanks for that. However, the Recorder does not work. It comes up with DLL Load fail .. Same thing that came when I tried manually to launch the Au3Record_x64.exe from the Extras menu. The error pops up when you click Record.

Any ideas as to what to do now ? If I use the normal version of the recorder, the bugs that I mentioned in my first happen will just repeat themselves.

Edit : Not sure if it is related, but I'm testing this on a simple game. When I press F, it uses a skill. Same thing goes for the other buttons. I'm wondering if the script look at when the keys were pushed when recording, and just runs all the keys in quick succession, meaning that most of the script doesn't work as it should. Also, how do I get the script to infinite loop ?

Edited by Distrance

Share this post


Link to post
Share on other sites

Instead of acting smartass, try things, then come back to the forum.

Your attempt at showing intelligence does not humor me.

The problem still remains with the recorder. Surely the recorder would not exist if the program was meant for '' real men '' who make their own code. I'm not able to do that and neither am I interested in practicing something that could take months to learn properly.

Now as for recording, I saved the project and the tools menu came visible so thanks for that. However, the Recorder does not work. It comes up with DLL Load fail .. Same thing that came when I tried manually to launch the Au3Record_x64.exe from the Extras menu. The error pops up when you click Record.

Any ideas as to what to do now ? If I use the normal version of the recorder, the bugs that I mentioned in my first happen will just repeat themselves.

The "recorder on x64" thing has been talked about before, do a search.

AutoIt takes minutes to learn.

And finally, the recorder records what it sees, not what you want it to do (although that would be neat). This is computers you know. If the resulting script is not as you want, then rewrite it yourself.

Share this post


Link to post
Share on other sites

I'm polite with who deserves it. He's going all the day long acting like that and sometimes not even givin useful replies. Useless.

Your attempt at showing intelligence does not humor me.

Implying that I feel in need to prove something to you.


I'm a compulsive poster. When I post something, come to read it at least 5 minutes later after the posting, because I will edit it. I edited even this signature a few minutes later after I wrote it.

Share this post


Link to post
Share on other sites

Your attempt at showing intelligence does not humor me.

The "recorder on x64" thing has been talked about before, do a search.

AutoIt takes minutes to learn.

And finally, the recorder records what it sees, not what you want it to do (although that would be neat). This is computers you know. If the resulting script is not as you want, then rewrite it yourself.

What do you mean it won't do what I want it to do ? If I press and hold F key until the skill finishes, then switch to D, do the same thing, then with S and finally with A .. Shouldn't it work like I've intended it to ? There is clearly something wrong with the recorder or runninng the script here .. The '' Send '' line contains all the keystrokes it should, which are identical to those that are on my working script with Ghost Control Pro program. The problem with this program is, that it is not free.

And for what you suggested .. By now you should know that I'm not good with stuff like this, and I don't think you should expect that either from me, or anyone on the internet by default. Yeah we're using computers, doesn't mean every user can program and make their own scripts and stuff.

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Like I said, a game. If you must know, the game is called LaTale and while it's an online mmo, I'm not using it to farm monsters or anything. ( It wouldn't be possible anyway .. aggro monsters and 2D sidescroller ) Like I said, I want to automate the crafting process even further but before I can do that, I need to get the program working properly. And to do that, I've experimented with the skills but if that doesn't work as intended, nothing else will either.

Does it really matter, can't you just help me with the problem at hand ?

I'm really fine with Ghost Controller so far, par the fact not being free so I can't run scripts longer than 30 seconds .. But I have several friends who can't get GC working for some reason so I really wish you could help me with this <.<

Edited by Distrance

Share this post


Link to post
Share on other sites

Does it really matter, can't you just help me with the problem at hand ?

It does. read the announcement at the top and stick to it.

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0