Sign in to follow this  
Followers 0
DanielDaniel

Adding scrollbar to Edit control

3 posts in this topic

Hi all,

I use the following code to add a multiline edit control to my form:

GUICtrlCreateEdit($line, 10, 80, 50, 310, $ES_MULTILINE)

Works great, but does anyone know how I can add scrollbars (horizontal and vertical) to the control if it contains more text than can be displayed?

Thanks,

DanielDaniel

Share this post


Link to post
Share on other sites



DanielDaniel,

By specifying a style, you have overwritten the default style which holds the scrollbars. :)

So you need to add them back in. Two possibilities:

- 1. Use the default style and add $ES_MULTILINE.

- 2. Add all the required styles yourself.

I strongly suggest reading the Setting Styles tutorial in the Wiki - it goes into much more detail and shows how you should add additional styles. :)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

DanielDaniel,

By specifying a style, you have overwritten the default style which holds the scrollbars. :)

So you need to add them back in. Two possibilities:

- 1. Use the default style and add $ES_MULTILINE.

- 2. Add all the required styles yourself.

I strongly suggest reading the Setting Styles tutorial in the Wiki - it goes into much more detail and shows how you should add additional styles. :)

M23

Doh! Thanks a lot. I'll read your post. :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0