Jump to content
Sign in to follow this  
Aktonius

Huge problem with obfuscator

Recommended Posts

Aktonius

>### current Func: _Timer_SetTimer
C:\Users\Marko\AppData\Local\Temp\OBsADB2.tmp(1392,1) Warning for line:$hCallBack = DllCallbackRegister($sTimerFunc, "none", "hwnd;int;uint_ptr;dword")

Tried dozens of things but nothing seems to work

Been searching on forum here and found some guys posting this but none really had practical solution.

I really really need to make this work, if someone can maybe post a trick to go around this?

Thanks in advance

Share this post


Link to post
Share on other sites
wraithdu

Then you didn't search enough. This is not a problem, it's a limitation of Obfuscator. There is no way Obfuscator can know the string content of a variable at runtime. This is only a warning if you are stripping unused functions or renaming functions during obfuscation. The simple solution is to add the timer function referenced by $sTimerFunc to the #Obfuscator_Ignore_Funcs directive. This solution has been presented many times before as well.

Edited by wraithdu

Share this post


Link to post
Share on other sites
Aktonius

Then you didn't search enough. This is not a problem, it's a limitation of Obfuscator. There is no way Obfuscator can know the string content of a variable at runtime. This is only a warning if you are stripping unused functions or renaming functions during obfuscation. The simple solution is to add the timer function referenced by $sTimerFunc to the #Obfuscator_Ignore_Funcs directive. This solution has been presented many times before as well.

Would this be correct format then?

Tried it but it doesnt work

#Obfuscator_Ignore_Funcs=timer1func, timer2func, timer3func

I apologize if this was solved and explained before but now i v found it, its just that it doesnt work for me :)

What could i do wrong?

I have latest obfs , i am using no obf parameters at all

Edited by Aktonius

Share this post


Link to post
Share on other sites
wraithdu

Yes, that's the correct format, assuming those are the names of your timer functions. To be safe, remove the spaces between the commas and the function names.

FYI, this will NOT get rid of the warning issued by Obfuscator. The warning is important and will always be issued when a Call() statement is used in your script or a UDF. However this will prevent the problems that you are being warned about. Run your script and test it!

It wouldn't hurt you to read the Obfuscator documentation as well so you actually KNOW what's happening when you don't give Obfuscator any specific parameters.

Share this post


Link to post
Share on other sites
Aktonius

Yes, that's the correct format, assuming those are the names of your timer functions. To be safe, remove the spaces between the commas and the function names.

FYI, this will NOT get rid of the warning issued by Obfuscator. The warning is important and will always be issued when a Call() statement is used in your script or a UDF. However this will prevent the problems that you are being warned about. Run your script and test it!

It wouldn't hurt you to read the Obfuscator documentation as well so you actually KNOW what's happening when you don't give Obfuscator any specific parameters.

Oh so the script could actually work :)

I didnt think of that, yes, yes reading it all np(was using no paras just to make sure its not the cause)

thanks

edit: HEUUUUUUREKA TIMERS FINALLY WORK, duh dor dur this costed me some time and headache(but i am imune to it after everything)

Edited by Aktonius

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.