Sign in to follow this  
Followers 0
DaleHohm

Hack to make the beta the default .exe?

5 posts in this topic

A while back I recall someone posting a hack that made the AutoIt3 in the \beta folder the default... I've searched and can't find it. Anyone have a pointer?

Thanks,

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites



this one?

#cs
vi:ts=4 sw=4:
DefaultAutoItToggle.au3
Ejoc
#ce
Opt("MustDeclareVars",1)
Local $InstallDir = RegRead("HKLM\Software\AutoIt v3\AutoIt","InstallDir")

If StringInStr(RegRead("HKLM\Software\Classes\AutoIt3Script\Shell\Run\Command",""),"beta") Then; already using beta switch back
    RegWrite("HKLM\Software\Classes\AutoIt3Script\Shell\Compile\Command","",_
            "REG_SZ",_
            $InstallDir & '\Aut2Exe\Aut2Exe.exe /in "%l"')
    RegWrite("HKLM\Software\Classes\AutoIt3Script\Shell\Run\Command","",_
            "REG_SZ",_
            $InstallDir & '\AutoIt3.exe "%1" %*')
    MsgBox(0,"Using","Using Release Version of AutoIt",2)
Else; change to beta
    RegWrite("HKLM\Software\Classes\AutoIt3Script\Shell\Compile\Command","",_
            "REG_SZ",_
            $InstallDir & '\beta\Aut2Exe\Aut2Exe.exe /in "%l"')
    RegWrite("HKLM\Software\Classes\AutoIt3Script\Shell\Run\Command","",_
            "REG_SZ",_
            $InstallDir & '\beta\AutoIt3.exe "%1" %*')
    MsgBox(0,"Using","Using beta Version of AutoIt",2)
EndIf

Start -> Programs -> AutoIt v3 -> AutoIt Help File -> Index -> (The Function you are asking about)----- Links -----DllStruct UDFsRSA Crypto UDFs

Share this post


Link to post
Share on other sites

Yeah! Thanks it -- thanks :)


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

i just use the zip and completly overwrite my old autoit.

<{POST_SNAPBACK}>

Yeah -- I was doing that too... I actually had a couple of occasions where I wanted to test with the production release (backwards from the normal beta scenario) and decided this would be better... this script is exactly what I wanted.

thanks,


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0