Sign in to follow this  
Followers 0
t0ddie

whats wrong here...

7 posts in this topic

RegWrite("HKLM\Software\Microsoft\Windows\Current Version\RunOnce", "my.exe", "REG_SZ", @ScriptDir & "\config\files\add ons\my.exe")

the file is right where it should be. i ran that line, then i restarted computer.

the computer started and my.exe never ran.

simple mistake im sure... but what??


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites



the file is right where it should be. i ran that line, then i restarted computer.

the computer started and my.exe never ran.

@ScriptDir is the path of your AU3 script. Is this really the Path-Prefix for your .exe ??

Cheers

Kurt


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

Could be the space in "add ons".

Try this:

RegWrite("HKLM\Software\Microsoft\Windows\Current Version\RunOnce", "my.exe", "REG_SZ", '"' & @ScriptDir & '\config\files\add ons\my.exe"')

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

probably the space. and yes.. the file is in the same parent directory as the script.

ill try that out.

EDIT: Nope.. not working still!

i just tried this

RegWrite("HKLM\Software\Microsoft\Windows\Current Version\RunOnce", "my.exe", "REG_SZ", '"' & @ScriptDir & '\config\files\add ons\my.exe"')

still nothing!!! just restarted the computer, it did not run.

Edited by t0ddie

Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

RegWrite("HKLM\Software\Microsoft\Windows\Current Version\RunOnce", "my.exe", "REG_SZ", @ScriptDir & "\config\files\add ons\my.exe")

the file is right where it should be. i ran that line, then i restarted computer.

the computer started and my.exe never ran.

simple mistake im sure... but what??

<{POST_SNAPBACK}>

There is a little speling prop.

RegWrite("HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce", "my.exe", "REG_SZ", @ScriptDir & "\config\files\add ons\my.exe")

Now this schould do the trix :)

Share this post


Link to post
Share on other sites

son of a BITCH... i didnt see that cause it looked right lol..

i had gotten SOMEONE ELSES TYPO!

thats what i get for copy and pasting others code from the forums lol!

CurrentVersion nice, thanks man.


Valik Note Added 19 October 2006 - 08:38 AMAdded to warn level I just plain don't like you.

Share this post


Link to post
Share on other sites

son of a BITCH... i didnt see that cause it looked right lol..

i had gotten SOMEONE ELSES TYPO!

thats what i get for copy and pasting others code from the forums lol!

CurrentVersion nice, thanks man.

<{POST_SNAPBACK}>

NP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0