Sign in to follow this  
Followers 0
Clanity184

_GUICtrlListViewGetItemText doesn't Work

8 posts in this topic

Hello to all.

Help please. I need use this function _GUICtrlListViewGetItemText, but in SciTE Editor appear like a black Text that generate error.

Sorry for my English and also for the ask, that can seem stupid, but I'm a dummies of autoIT.

Thanks for answers.

Share this post


Link to post
Share on other sites



Please post some sample code that we can look at.

Share this post


Link to post
Share on other sites

Please post some sample code that we can look at.

I'm not on the pc were I'm working to the project, but my need is to use this function to extract from a listview the items selected.

I have seen the same black text (ex.:__UDF_ValidateClassName, _MemInit) in GUICtrlListView.au3 file (Include folder of the program AutoIt) that, I suppose is the source code of all the GUICtrlListView functions.

Seems that some references lack.

Share this post


Link to post
Share on other sites

Colored functions is colored just because they are set so in one of the configuration files, just ignore it and continue coding.

In this particular case, you forget a underscore, it should be _GUICtrlListView_GetItemText()

Share this post


Link to post
Share on other sites

Colored functions is colored just because they are set so in one of the configuration files, just ignore it and continue coding.

In this particular case, you forget a underscore, it should be _GUICtrlListView_GetItemText()

Thanks a lot,

now after the underscore text is become azure.

Seems strange, but I have found this function or module, like is written, _GUICtrlListViewGetItemText() in example files download with the installation program.

Now I'll try to continue my coding work.

Share this post


Link to post
Share on other sites

Seems strange, but I have found this function or module, like is written, _GUICtrlListViewGetItemText() in example files download with the installation program.

Really? What files? If I use SciTE's "Find In Files" on my AutoIt3 folder there's nothing like that.

Share this post


Link to post
Share on other sites

It seems to me that might have been the function name way back before all of the old GUI library files were updated which would indicate he dragged it up from a very old thread.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

You are right on the first part, but he said it was from the install, which we has to assume he meant AutoIt/SciTE4AutoIt, and the only code that has that function is CodeWizard.au3 but that isn't a example, so Clanity's statement fail completely.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0