Sign in to follow this  
Followers 0
YadidaBoobOo

Am I Missing Something?

1 post in this topic

I've read through a bunch of threads, and searched before I posted, I don't see why my script is getting hung up. This is what I am currently running:

;
;
; VPN Access
;
;

    $oIE = _IECreate("https://vendoraccess.twcable.com")

        If WinWaitActive("Security Alert", "information you exchange", 3) Then
            Send("{ENTER}")
        EndIf

        WinWaitActive("Vendor Access SSL-VPN")
        $iedone = "false"
        While $iedone <> "Done"
            $iedone = StatusbarGetText("Vendor Access SSL-VPN")
        WEnd
        Send($vpnauser, 1)
        Send("{TAB}")
        Send("^v")
        Send("{TAB}")
        Send("{ENTER}")     

        If WinWaitActive("samproxy", "", 3) Then
            Send("{ENTER}")
        EndIf
        Sleep(13500)

;
;
; Totalview (WFM SUCKS!)
;
;
    $oIE = _IENavigate($oIE, "http://totalview/", 1, 2048)
        If WinWaitActive("Security Alert", "information you exchange", 3) Then
            Send("{ENTER}")
        EndIf

        WinWaitActive("TotalView")
        $iedone = "false"
        While $iedone <> "Done"
            $iedone = StatusbarGetText("TotalView")
        WEnd
        Send($totauser, 1)
        Send("{TAB}")
        Send($totapass, 1)
        Send("{TAB}")
        Send("{ENTER}")

        If WinWaitActive("AutoComplete", "passwords", 3) Then
            Send("{ENTER}")
        EndIf

;
;
; Beaver
;
;

    $oIE = _IENavigate($oIE, "http://beaver/call%20logging/calllog.nsf", 1, 2048)

        If WinWaitActive("Security Alert", "information you exchange", 3) Then
            Send("{ENTER}")
        EndIf

        WinWaitActive("Server Login")
        $iedone = "true"
        While $iedone <> "Done"
            $iedone = StatusbarGetText("Server Login")
        WEnd
        Send($beavuser, 1)
        Send("{TAB}")
        Send($beavpass, 1)
        Send("{ENTER}")

        If WinWaitActive("AutoComplete", "passwords", 3) Then
            Send("{ENTER}")
        EndIf

Now my code will open the first window labeled VPN Access, Open a tab for "Total View" and then it freezes and the code stops, If I change all the code's to IECreate's then they all openup in new windows, I've even tried the

$oIE = _IECreate("https://issuetrak.twcable.com/beta.aspx", 1)

code which from what I understand, the 1 makes it try to open in an existing window? Maybe I am missing something? Thanks in advance, just want to know how to keep opening more tabs instead of freezing up after opening just 2.

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0