Sign in to follow this  
Followers 0
Wiggyboy

Problem with my script

16 posts in this topic

#1 ·  Posted (edited)

Hey xD, I'm working on a scipt and got the problem that it didn't rly work fully on my friend, so first i thought it was just cuz he had a Vista, but then i found out it didn't work for my friends who have 7 either, so i figure'd out why it didn't work... they have to run the program as administor... but the script i'm working on now uses more then 1 au3/exe file so it doesn't work at all for my friends... is there anyhow i could fix this??

EDIT: okey as u complain about not posting any code i'll give u some...

Since i don't rly know exactly everything but as much as i know is that these commands won't work on Vista or 7 if ur not running the program as administrartor

Filecopy()
Run()

while i was searching alittle bit i found out u could actully do

RunAs()
but then i would need the username and password, any1 know how i could get that?? Edited by Wiggyboy

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

blah blah blah what?

Seriously, stop with the ebonics, show the code that doesn't work.

No one here has a crystal ball.

Edit:

A crystal ball that really works that is.

Edited by SmOke_N

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

blah blah blah what?

Seriously, stop with the ebonics, show the code that doesn't work.

No one here has a crystal ball.

Edit:

A crystal ball that really works that is.

blah blah blah my ass, it's not the code which is not working -.-' if u might read it, and if u read it, READ IT AGAIN... u might understand my problem, else be nice and leave no comment further

Share this post


Link to post
Share on other sites

blah blah blah my ass, it's not the code which is not working -.-' if u might read it, and if u read it, READ IT AGAIN... u might understand my problem, else be nice and leave no comment further

I do not think that you should shout at a mod, it is not healthy.


Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

I do not think that you should shout at a mod, it is not healthy.

Let me elaborate on that: I don't think he should shout at anybody after creating a post like that.

@Wiggyboy,

Clear ?


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

@Wiggyboy,

1st do they have all the .exe they need to run?

2nd are they (the exes) in the same directory structure as yours are?

3rd are you logged in as an admin when running your script?

Share this post


Link to post
Share on other sites

I do not think that you should shout at a mod, it is not healthy.

Well, if this very nice mod would be nice to read everything and understand it it wouldn't have to get mad...

Let me elaborate on that: I don't think he should shout at anybody after creating a post like that.

@Wiggyboy,

Clear ?

Well, obisly it's not good to shout, but sometimes i get mad or pissed off... and i think his post is pretty lame, since he ain't even near talking about what i needed help about...

Doesn't #RequireAdmin solve that problem?

thanks but... i didn't want it to requireadmin, i wanted it to not requiteadmin Dx

Share this post


Link to post
Share on other sites

without posting any type of code, how do you expect any type of help?

just my two bits

Share this post


Link to post
Share on other sites

without posting any type of code, how do you expect any type of help?

just my two bits

Well, as i've said before... it's still not the script which doesn't work...

Share this post


Link to post
Share on other sites

Well, as i've said before... it's still not the script which doesn't work...

so, if it's not the script, then why even post on here then?

Share this post


Link to post
Share on other sites

Well, as i've said before... it's still not the script which doesn't work...

Well with out more information about the "enviroments" the script and pcs are in. Not much they can do to help you.

However with that said, it does appear to me, and I am sure it has crossed the minds of a few people here already, that since you are refusing to post any type of code example, your code is part of those forbidden subjects. Which if posted would result in a locked thread.

So pony up or figure it out on your own and quit being a dick to people here for trying to help.

Share this post


Link to post
Share on other sites

Well, if this very nice mod would be nice to read everything and understand it it wouldn't have to get mad...

Well, obisly it's not good to shout, but sometimes i get mad or pissed off... and i think his post is pretty lame, since he ain't even near talking about what i needed help about...

Your post was far from easy to understand. It was written poorly all together. It wasn't me being a dick, with people that put little time in explaining their situation literately, their code usually speaks for itself and issues are quickly found ( Rather than trying to rack our brains on trying to decipher someones cryptic request help).

"This doesn't work on Windows 7". Ok... What doesn't work, where is it failing, etc...

thanks but... i didn't want it to requireadmin, i wanted it to not requiteadmin Dx

If you're running something that is forcing you to "RequireAdmin", you have two choices.

1. Make them turn off their UAC.

2. Purchase a code sign from someone like Verisign and start signing your executables.

The other side of that, is if you're actually wanting to perform admin type task on a non-admin account, without the admin username and password.. Forget it.


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

so, if it's not the script, then why even post on here then?

Becouse the script won't execute as it should, and maybe there is some command to make it not care about admin rights...

Well with out more information about the "enviroments" the script and pcs are in. Not much they can do to help you.

However with that said, it does appear to me, and I am sure it has crossed the minds of a few people here already, that since you are refusing to post any type of code example, your code is part of those forbidden subjects. Which if posted would result in a locked thread.

So pony up or figure it out on your own and quit being a dick to people here for trying to help.

Well, since it's not the code which is incorrect or doesn't work why would i waste time on putting up the code here, since it's to no use... it's about admin rights... not about an error...

Your post was far from easy to understand. It was written poorly all together. It wasn't me being a dick, with people that put little time in explaining their situation literately, their code usually speaks for itself and issues are quickly found ( Rather than trying to rack our brains on trying to decipher someones cryptic request help).

"This doesn't work on Windows 7". Ok... What doesn't work, where is it failing, etc...

If you're running something that is forcing you to "RequireAdmin", you have two choices.

1. Make them turn off their UAC.

2. Purchase a code sign from someone like Verisign and start signing your executables.

The other side of that, is if you're actually wanting to perform admin type task on a non-admin account, without the admin username and password.. Forget it.

Well sorry if i'ven't got the best english but if u don't understand it and i maybe wrote it pretty bad u could ask me to try explaining it somehow else...

and what's failing, since i've edited it says which commands which doesn't execute... idk why...

Filecopy()
Run()

Share this post


Link to post
Share on other sites

Still pretty hard to diagnose without knowing exactly what error message or exact failure mode you're getting.

If you want to use RunAs(), it can't "get" the password. Either your friend gives it to you and you hard code it into the script (or an ini file or something like that), or you pop up an input box to ask for it, then pass it to the RunAs function.

On the other subject, this is a web forum, not a chat board or cellphone. Using normal English instead of kiddie chatspeak abbreviations goes a long way in having people take you seriously. You wouldn't leave most of the letters out of a function call and expect it to work, so why would you leave most of the letters out words of a forum post and expect to get results?

Share this post


Link to post
Share on other sites

Vista and 7 are only going to need Admin permission when you are trying to do stuff in the protected areas. These include:

- root of the system volume where Windows is located

- Program Files folder

- Windows folder

- any User folder besides Public

- in any other folders that are flagged +S or +H (System or Hidden)

- the files in question are not owned by the logged in user or other permissions issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0