Sign in to follow this  
Followers 0
JBeardNC

Error opening destination file

3 posts in this topic

I did a search and saw a couple of posts about this but not this particular issue. Ever since I upgraded to Windows 7, if I have Windows Explorer opened and I'm browsed to the destination directory of the compiled script, and I attempt to compile or build, I get the "Error opening destination file" message. As soon as I go to the parent directory in Explorer, compiling works as it should. It appears that Windows Explorer is somehow forcing the compiled .exe to be read-only when that directory is opened. I've noticed that even if I have the compiled .exe highlighted in Windows Explorer on a completely separate machine (I write my scripts on my computer but test them on another), that this prevents me from successfully compiling the script. Yet as soon as I go to the parent directory or really any other directory but the destination, I have no issues. I'm not sure if this is a Windows 7 issue (it does not happen on XP) or if its an issue with my AutoIt installation but wanted to get some feedback from the community to see if anyone else experiences this strange behavior. Obviously, its not a show stopper, just an annoyance, but if theres an easy fix I'm overlooking, I'd love to hear it. I find myself always checking what Explorer windows I have opened now before I can compile any scripts.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Its a Win7 issues and I have no simple way around it yet but do believe that the current beta version of Autoit3Wrapper work a little better and doesn't always give this problem anymore. It now does a FileDelete() of the target EXE file just before running aut2exe and waits a brief moment.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I know this is an old post. You can right click on Aut2exe.exe file -> Properties, then click on Compatibility to change compatibility mode to suite your OS. Make sure the "Run this program as an administrator" checkbox is checked. Click OK. Then try to compile your au3. You should be able to convert it to exe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0