Sign in to follow this  
Followers 0
LeviStevens

Using INI for build does not set file version (resources)

5 posts in this topic

I am attempting to automate the build of all my scripts files, but I want to increment the version. When I use the Aut2exe.exe command with the /in /out switches it doesn't seem to honor the values in the SCRIPTNAME.INI file.

Is there something I'm missing to get this to work?

DellClean.au3

DellClean.ini

;AutoIt section for aut2exe and AutoIt3

[Autoit]

;aut2exe=

Icon=.\images\dell_icon.ico

OutfileType=DellClean.exe

;Compression=

;PassPhrase=

Allow_Decompile=n

UseUpx=n

UseAnsi=n

;Resource update section

[Res]

Language=1033

Comment=Dell cleanup

Description=Dell cleanup

Fileversion=1.0.100

LegalCopyright=Dell, Inc

;Field1Name=

;Field1Value=

;Field2Name=

;Field2Value=

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

This INI file isn't used by AUT2EXE but by Autoit3Wrapper. Have you installed the full version of SciTE4AutoIt3?

oh and that should be scriptfile.au3.ini

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

This INI file isn't used by AUT2EXE but by Autoit3Wrapper. Have you installed the full version of SciTE4AutoIt3?

oh and that should be scriptfile.au3.ini

Jos

Now I am using "AutoIt3Wrapper.exe /in C:\Test\Test.au3" however it still is not using any of the settings when I compile. It isn't using the icon or the version.

Any ideas here?

Test.au3.ini:

;AutoIt section for aut2exe and AutoIt3

[Autoit]

;aut2exe=

Icon=.\images\Test.ico

OutfileType=c:\BUILD\Test.exe

;Compression=

;PassPhrase=

Allow_Decompile=n

UseUpx=n

UseAnsi=n

;Resource update section

[Res]

Language=1033

Comment=Test Comment

Description=Test Description

Fileversion=1.0.1

LegalCopyright=Dell, Inc

;Field1Name=

;Field1Value=

;Field2Name=

;Field2Value=

[Other]

Run_AU3Check=Y

AU3Check_Stop_OnWarning=Y

;AU3Check_Parameter=

;Run_Before=

;Run_After=

;[Config]

;ResHackerPath=

;RCExePath=

Share this post


Link to post
Share on other sites

Show me all information shown in the SciTE output pane when you hit F7 so I can see what is actually happening.

Jos :huh2:


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Show me all information shown in the SciTE output pane when you hit F7 so I can see what is actually happening.

Jos :)

Jos,

It turned out that what I was doing wrong was that I needed to set the #AutoItWrapper directives in the AU3 script itself. If I tried to use an INI file it just prompted me to add the "Legacy" detail into the AU3 and then duplicated the entries. I updated my build projects script to open the AU3 and change the AutoIt3 directives on the fly with the location and build number. This resolved my issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0