Sign in to follow this  
Followers 0
Elleric

upper/lower case?

7 posts in this topic

I am at a loss here. I have to send a capital V to the tera term window. Generally I prefer to use ControlSend() for this... just seems safer.

Using the Send() method as below, i get the expected capital V... yay!

WinActivate("Tera Term")
Send("+v")

But when i use the ControlSend() method as below, i get a lower case v... grrrr!

WinActivate("Tera Term")
ControlSend("Tera Term", "", "", "+v", 0)

Id really like to use controlsend() for the added robustness but i cant for the life of me figure out why it keeps sending lower cases... is there some setting i am missing for the + to work?

Thank you~!

Share this post


Link to post
Share on other sites



Look at the syntax for ControlSend()

You are missing the ControlID


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

There is know bug/limitation in Send/ControlSend with some national keyboard layouts (other than english).

Behavoiur is exactly as you describe.

I discovered this many years ago. There are some topics about that.

Known workarounds are these:

1) use ControlSetText() instead of ControlSend() if possible

2) change keyboard layout to English before ControlSend() and revert it back after it

Share this post


Link to post
Share on other sites

Look at the syntax for ControlSend()

You are missing the ControlID

As far as I know this is "undocumented" function:

When ControlID is empty then control which has focus (in that window) is used.

Share this post


Link to post
Share on other sites

As far as I know this is "undocumented" function:

When ControlID is empty then control which has focus (in that window) is used.

Yes, the correct window is being sent the data and it is being put in the correct place. The issue is just it's sending a lower case v rather than upper...

here is something else a little goofy...

If I open a new script and just put

Opt("WinTitleMatchMode", 2)
WinActivate("Tera Term")
ControlSend("Tera Term", "", "", "+v", 0)

it works >< and makes me want to throw my computer out the window. Which is what lead me to thinking there was some setting that is being tripped. Currently the only other code being run is a UI bit I Imported.

Related to one of the above posts, I am in the US, I'm fine with using a US keyboard at all times. How is that set?

Share this post


Link to post
Share on other sites

Related to one of the above posts, I am in the US, I'm fine with using a US keyboard at all times. How is that set?

That's weird. In this case I can't help you more :-(

Share this post


Link to post
Share on other sites

Rather than +v maybe try just a capitol V

WinActivate("Tera Term")
ControlSend("Tera Term", "", "", "V")

Works in my scripts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0