Jump to content
Sign in to follow this  
Zedna

[Solved] Scite4Autoit3 - F1 doesn't work

Recommended Posts

Zedna

I have got new Windows7 64bit system at work and in my full Scite editor doesn't work F1 (Help). Nothing happens after pressing F1 or invoking F1 Help directly from Scite menu.

I Installed Autoit 3.2.12.1 release then full Scite4Autoit3 then beta 3.3.7.X (reinstalled several beta versions with uninstal previous beta option ON).

Note that Alt+F1 (Help for Beta) work OK.

How can I fix this?

EDIT: Solution is in post #26

Edited by Zedna

Share this post


Link to post
Share on other sites
Zedna

Just save the (untitled,new) file and try again :)

That's not my case.

My problem is also when I open existing (not new) AU3 file from explorer (doubleclick on AU3 opens it into Scite). F1 still doesn't work.

Edited by Zedna

Share this post


Link to post
Share on other sites
Zedna

Here is Scite Output from test script (F5 - Run)

3.2.12.1 release

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "C:\111\test.au3" /autoit3dir "C:\Program Files (x86)\AutoIt3" /UserParams    
+>15:00:12 Starting AutoIt3Wrapper v.2.0.1.24   Environment(Language:0405  Keyboard:00010405  OS:WIN_7/  CPU:X64 OS:X64)
>Running AU3Check (1.54.13.0)  from:C:\Program Files (x86)\AutoIt3
+>15:00:13 AU3Check ended.rc:0
>Running:(3.2.12.1):C:\Program Files (x86)\AutoIt3\autoit3.exe "C:\111\test.au3"    
+>15:00:15 AutoIT3.exe ended.rc:0
>Exit code: 0   Time: 3.038

3.3.7.14 beta

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:\111\test.au3" /autoit3dir "C:\Program Files (x86)\AutoIt3\beta" /UserParams   
+>15:01:43 Starting AutoIt3Wrapper v.2.0.1.24   Environment(Language:0405  Keyboard:00010405  OS:WIN_7/  CPU:X64 OS:X64)
>Running AU3Check (1.54.21.0)  from:C:\Program Files (x86)\AutoIt3\Beta
+>15:01:43 AU3Check ended.rc:0
>Running:(3.3.7.14):C:\Program Files (x86)\AutoIt3\Beta\autoit3.exe "C:\111\test.au3"   
+>15:01:46 AutoIT3.exe ended.rc:0
>Exit code: 0   Time: 3.529

Aditional notes:

- At install process I checked (default) option for using X86 (and not X64) version of all Autoit EXE files for backward compatibility.

- I noticed that Autoit3Wrapper is in Running processes 2x (in two instances) when some script is running.

Share this post


Link to post
Share on other sites
BrewManNH

Try right clicking the Scite executable and go to properties. Select the compatibility tab and click Run As Administrator. Every time you open Scite after that you'll need to accept the UAC prompt, but it will probably fix the issue. If AutoIt3 is installed in the default location (Program Files) then Win7 will block a lot of attempts at saving/opening files from that program.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
Zedna

Try right clicking the Scite executable and go to properties. Select the compatibility tab and click Run As Administrator. Every time you open Scite after that you'll need to accept the UAC prompt, but it will probably fix the issue. If AutoIt3 is installed in the default location (Program Files) then Win7 will block a lot of attempts at saving/opening files from that program.

I have got UAC switched OFF. Such prompts at every other thing are absolutely stupid. In Windows XP there is no such UAC shit and no one complains about missing "security".

I use account with administrators privileges so I tried this option (Run Scite.exe as Administrator) and no prompt was at running. But F1 still doesn't work.

Share this post


Link to post
Share on other sites
Zedna

Here is link to topic with usefull script for testing of Autoit/Scite configuration

and my output:

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:\Program Files (x86)\AutoIt3\autoit shell config list.au3" /autoit3dir "C:\Program Files (x86)\AutoIt3\beta" /UserParams   
+>18:04:28 Starting AutoIt3Wrapper v.2.0.1.24   Environment(Language:0405  Keyboard:00010405  OS:WIN_7/  CPU:X64 OS:X64)
>Running AU3Check (1.54.21.0)  from:C:\Program Files (x86)\AutoIt3\Beta
+>18:04:28 AU3Check ended.rc:0
>Running:(3.3.7.14):C:\Program Files (x86)\AutoIt3\Beta\autoit3.exe "C:\Program Files (x86)\AutoIt3\autoit shell config list.au3"   
+****************************************************************************************
+* Current setting: 
+*      Default action:Open
+*                  Run:"C:\Program Files (x86)\AutoIt3\AutoIt3.exe" "%1" %2 %3 %4 %5 %6 %7 %8 %9
+*                  Open:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
+*                  Edit:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
+****************************************************************************************
+*  Explorer shell options
+*                          Compile => Command:"C:\Program Files (x86)\AutoIt3\Aut2Exe\Aut2Exe.exe" /in "%l"
+*                          Compile with Options => Command:"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /ShowGui /in "%l"
+*                          Edit => Command:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
+*                          Open => Command:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
+*                          Run => Command:"C:\Program Files (x86)\AutoIt3\AutoIt3.exe" "%1" %2 %3 %4 %5 %6 %7 %8 %9
+*                          Tidy => Command:"C:\Program Files (x86)\AutoIt3\SciTE\Tidy\Tidy.exe" "%1"
+****************************************************************************************
+*  .au3 Default :AutoIt3ScriptBeta
+*  .au3 PreceivedType :
+*  .au3 ShellNew Default:
+*  .au3 ShellNew Filename:Template.au3   Exists:1
+>18:04:28 AutoIT3.exe ended.rc:0
>Exit code: 0   Time: 1.033
Edited by Zedna

Share this post


Link to post
Share on other sites
Zedna

Zedna,

You say you installed Autoit 3.2.12.1 ?

Does that contain program: AutoIt3Help.exe ?

Jos

I use Autoit 3.2.12.1 because many of my scripts (all) are compatible with this version.

The same configuration (3.2.12.1 as release and 3.3.7.14 as latest beta) works fine on my Windows XP.

Now I checked that AutoIt3Help.exe is on my Windows7 too.

I can remember that many years ago there was some similar problem with F1 key in Scite: while script was running from Scite (ran by F5) then F1 didn't work until script finished. But now F1 doesn't work even if no script is running.

Edited by Zedna

Share this post


Link to post
Share on other sites
trancexx

Sorry for off-topic, but it's simply unbelievable to me that anyone can say this:

I have got UAC switched OFF. Such prompts at every other thing are absolutely stupid. In Windows XP there is no such UAC shit and no one complains about missing "security".

Every word is wrong.

♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites
MvGulik

Blee, Fuck it. Never mind.

Edited by iEvKI3gv9Wrkd41u

"Straight_and_Crooked_Thinking" : A "classic guide to ferreting out untruths, half-truths, and other distortions of facts in political and social discussions."
"The Secrets of Quantum Physics" : New and excellent 2 part documentary on Quantum Physics by Jim Al-Khalili. (Dec 2014)

"Believing what you know ain't so" ...

Knock Knock ...
 

Share this post


Link to post
Share on other sites
Zedna

Sorry for off-topic, but it's simply unbelievable to me that anyone can say this:

Every word is wrong.

Every word is right!!

Not all Microsoft's "improvements" are good. UAC is crapy shit. Fortunatelly it can be disabled.

Period.

Share this post


Link to post
Share on other sites
trancexx

Enjoy your ignorance.


♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites
GEOSoft

actually I just had the same problem a couple of days ago and I'm not sure why yet. I did manage to fix it even though I'm not sure why it happened to begin with.

Go to the AutoIt3\Scite\Properties\au3.properties file and look at line 7. Make sure that path is correct.

I had it change on me a couple of times when I was only using 1 install of Scite on 3 operating systems. I've now changed this but I went to use F1 on the day in question and ooooops.

Looked at the file and instead of program files it had program files (x64) (or (x86) I forget now) and there is no such folder on any of my OSs because I only run x86 OSs

I was actually going to PM Jos about that so you may have just saved him all that aggrevation but took some fun out of my life doing it.

EDIT:

BTW, I've now made that file read-only so I don't get changes that I don't know about.

Edited by GEOSoft

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites
Zedna

Enjoy your ignorance.

You have big problems to accept different opinions of other people! ;)

UAC is optional and users can disable it if they don't like it.

I don't like it and therefore I disabled UAC on my machine.

So what's the problem?!?

I can remember you made more rude reactions to me already :)

so please stay out of such rude reactions/attacks, thanks.

Edited by Zedna

Share this post


Link to post
Share on other sites
Zedna

Go to the AutoIt3\Scite\Properties\au3.properties file and look at line 7. Make sure that path is correct.

Thanks!!

Now I'm not on Win7 X64 machine, I will check that as soon as possible and I will post here the resolution.

Edited by Zedna

Share this post


Link to post
Share on other sites
trancexx

You have big problems to accept different opinions of other people! ;)

UAC is optional and users can disable it if they don't like it.

I don't like it and therefore I disabled UAC on my machine.

So what's the problem?!?

Your ignorance, I already said that.

I can remember you made more rude reactions to me already :)

so please stay out of such rude reactions/attacks, thanks.

Sure. I was really rude. I'll try not to attack you next time, especially not rudely.

♡♡♡

.

eMyvnE

Share this post


Link to post
Share on other sites
Zedna

Thanks!!

Now I'm not on Win7 X64 machine, I will check that as soon as possible and I will post here the resolution.

It seems OK:

"C:\Program Files (x86)\AutoIt3\SciTE\Properties\au3.properties" --> line 7:

autoit3dir=C:\Program Files (x86)\AutoIt3

Maybe there is some problem with VirtualStore directory. I noticed some similar problems with another application which couldn't find some DLL and it was there.

I can see VirtualStore Autoit3 directory here:

"C:\Users\xxxxx\AppData\Local\VirtualStore\Program Files (x86)\AutoIt3\"

There is Scite subdirectory and inside it are these files:

Koda\fd.xml

Obfuscator\Obfuscator.log

Maybe Scite is searching AutoitHelp.exe in this VirtualStore directory on F1? But Alt+F1 works fine!

I'm confused.

I will try to install latest beta version of Scite4Autoit3 and its components.

Share this post


Link to post
Share on other sites
Zedna

I will try to install latest beta version of Scite4Autoit3 and its components.

Installed and no change.

I tried to set "c:\Program Files (x86)\AutoIt3\" to PATH and still no change :-(

So F1 from Scite doesn't work.

What else should I try?

Share this post


Link to post
Share on other sites
GEOSoft

If Alt+F1 is working then I would suspect that it's a bit more of a basic problem.

You might want to uninstall/reinstall the release version of AutoIt. In fact I would do both the release and the beta versions then install Scite4AutoIt3 just as if you were doing a first time setup.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×