Jump to content
Sign in to follow this  
bumitrue93

Searching for a specific word in IE

Recommended Posts

bumitrue93

Am totally new to autoit. i am trying to make a bot where the bot reads/checks whether theres a specific word in the page (for example "apple".)

the bot then tries to click the link.

i tried searching the forums and found out the _IE functions.

i can't understand the "_IE_Example" and also "_IEBodyReadHTML($oIE)" -(the $oIE part)-

what argument should i pass in it as to make it read the page?

~thanks~

Share this post


Link to post
Share on other sites
Jos

Am totally new to autoit.

Great... first just start with reading the forum rules because I am sure you didn't do that yet. :)

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
flet

I think you need the function _IELinkClickByText()

$oIE = _IECreate("yourrurl")

_IELinkClickByText ($oIE, "apple")

Share this post


Link to post
Share on other sites
bumitrue93

Great... first just start with reading the forum rules because I am sure you didn't do that yet. ;)

honestly i did :)

Share this post


Link to post
Share on other sites
bumitrue93

I think you need the function _IELinkClickByText()

$oIE = _IECreate("yourrurl")

_IELinkClickByText ($oIE, "apple")

i don't want it to run a new window every time i run the bot. and also is there a way to just use opera or any other browser?

Edited by bumitrue93

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.