Sign in to follow this  
Followers 0
Dronzul

Can't run any programs :(

14 posts in this topic

Hi, i've just started at AutoIT programming, and need some help. I cant run any programs, let me show you the code i write when i write:

;

; AutoIt Version: 2.x

; Language: English

; Platform: Win9x/NT

; Author: A.N.Other (myemail@nowhere.com)

;

; Script Function:

; Template AutoIt script.

;

Run, "C:\Program Files\Internet Explorer\IEXPLORE.exe"

But when i try to run the AutoIT file, a window pops up and says unable to run it, check if backslashes are placed correct. I am not using a US version of windows, can that be why?

Thanks in advance

Share this post


Link to post
Share on other sites



Hi, i've just started at AutoIT programming, and need some help. I cant run any programs, let me show you the code i write when i write:

;

; AutoIt Version: 2.x

; Language:      English

; Platform:      Win9x/NT

; Author:        A.N.Other (myemail@nowhere.com)

;

; Script Function:

; Template AutoIt script.

;

Run, "C:\Program Files\Internet Explorer\IEXPLORE.exe"

But when i try to run the AutoIT file, a window pops up and says unable to run it, check if backslashes are placed correct. I am not using a US version of windows, can that be why?

Thanks in advance

<{POST_SNAPBACK}>

Run("C:\Program Files\Internet Explorer\IEXPLORE.exe")

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Hi, i've just started at AutoIT programming, and need some help. I cant run any programs, let me show you the code i write when i write:

;

; AutoIt Version: 2.x

; Language:       English

; Platform:       Win9x/NT

; Author:         A.N.Other (myemail@nowhere.com)

;

; Script Function:

; Template AutoIt script.

;

Run, "C:\Program Files\Internet Explorer\IEXPLORE.exe"

But when i try to run the AutoIT file, a window pops up and says unable to run it, check if backslashes are placed correct. I am not using a US version of windows, can that be why?

Thanks in advance

<{POST_SNAPBACK}>

First off next time if you post a question about v2 post in v2 support. Also if you just started using AutoIt use V3. It is much much much better than V2. Now about your question. Have you tried Run, "IExplore.exe" without putting the path. This should work because if you use Start>Run and type in IExplore.exe it works. Edited by SolidSnake

HKTunes:Softpedia | GoogleCodeLyricToy:Softpedia | GoogleCodeRCTunes:Softpedia | GoogleCodeMichtaToolsProgrammer n. - An ingenious device that turns caffeine into code.

Share this post


Link to post
Share on other sites

Where did you get this ???

Run, "C:\Program Files\Internet Explorer\IEXPLORE.exe"

help states as this

Run("Notepad.exe", "", @SW_MAXIMIZE)

so, you want this

Run("C:\Program Files\Internet Explorer\IEXPLORE.exe")

see help for more details

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Wow 3 at a time... lol

:8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Where did you get this ???

Run, "C:\Program Files\Internet Explorer\IEXPLORE.exe"

help states as this

Run("Notepad.exe", "", @SW_MAXIMIZE)

so, you want this

Run("C:\Program Files\Internet Explorer\IEXPLORE.exe")

see help for more details

8)

<{POST_SNAPBACK}>

He is using v2. The syntax is different.

HKTunes:Softpedia | GoogleCodeLyricToy:Softpedia | GoogleCodeRCTunes:Softpedia | GoogleCodeMichtaToolsProgrammer n. - An ingenious device that turns caffeine into code.

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

He is not using V3. He is using V2.

<{POST_SNAPBACK}>

Ok, never used V2...

But isn't this the wrong forum? :)

EDIT: UM... you already told him that... sorry didn't see that we all posted all at the same time :evil:

Edited by ronsrules

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

My bad

thanks for pointing that out... it was before my time here

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Ok, never used V2...

But isn't this the wrong forum?  :)

EDIT:  UM... you already told him that... sorry didn't see that we all posted all at the same time  :evil:

<{POST_SNAPBACK}>

My bad

thanks for pointing that out... it was before my time here

8)

<{POST_SNAPBACK}>

I used it a long time ago. V3 is so much better.

The difference between v2 and v3 is like even bigger than the difference between Windows 3.1 and Windows 95. :D

Edited by SolidSnake

HKTunes:Softpedia | GoogleCodeLyricToy:Softpedia | GoogleCodeRCTunes:Softpedia | GoogleCodeMichtaToolsProgrammer n. - An ingenious device that turns caffeine into code.

Share this post


Link to post
Share on other sites

Ok thanks for every help, where do i get V3? I cant find it under the download section :S

PS: Run ("C:\Program Files\Internet Explorer\IEXPLORE.exe") didnt work :)

Share this post


Link to post
Share on other sites

Ok thanks for every help, where do i get V3? I cant find it under the download section :S

Here you go Dronzul!

Regards,

Alex Peters

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Thanks alot, i've been there but it just looked like it werent V3

Edited by Dronzul

Share this post


Link to post
Share on other sites

I remember using v2 for ages - had to double \\ for path names if memory serves me correct.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0