Jump to content
Sign in to follow this  

Send("!n") fails

Recommended Posts



As plain newbee a colleague pointed me to AutoIt and enthusiastically I started to dig into it.

I tried the following example script:

;This is my first script

;F. Mellink


MsgBox(0, "Step 1", "Start Notepad")


WinWaitActive("Untitled - Notepad")

MsgBox(0, "Step 2", "Add some text")

Send("AutoIT is easy and powerful.")

Send("It is user friendly and can be integrated in shell applications")

MsgBox(0, "Step 3", "Close Notepad")

WinClose("Untitled - Notepad")

MsgBox(0, "Step 4", "acknowledge")

WinWaitActive("Notepad", "Do you want to save")


However the last Send command doesn't close Notepad as it is supposed to do. I run AutoIt in Win7-64bit. Maybe that is the problem?

Who can help me out?

Share this post

Link to post
Share on other sites

See this post,

- Bruce /*somdcomputerguy */  If you change the way you look at things, the things you look at change.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.