Sign in to follow this  
Followers 0
Decker87

Send() not working with a particular program

4 posts in this topic

I'm in a very strange situation. The "Q" button on my keyboard has stopped working. Unfortunately one of my favorite games, League of Legends, uses this key extensively while providing no reliable way to remap the keys. So I figured, 'no big deal', I'll just configure a script to send Q when I press a different key (in my case A).

Here's the thing: The function executes just fine, but the game doesn't pick up the keystroke. It's as if the keystroke was never sent. Why might this be and is there a way to fix it?

Note: I am not trying to automate any aspect of the game, so I believe this is not in violation of the rules (which I have read).

Share this post


Link to post
Share on other sites



You could always buy a new keyboard, it would be easier



Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

Yes, but I have a $200 keyboard that I can't replace for another couple weeks. Do you have any idea on how to fix the problem of AutoIt Send() failing?

Share this post


Link to post
Share on other sites

A $200 KEYBOARD? WTF. Who makes it?

Have you tried it where the keys are sent raw? Also verifed for example with notepad that it is indeed sending the key?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0