Jump to content
Sign in to follow this  
Ontosy

aut2exe AutoIt3Wrapper path ini

Recommended Posts

Ontosy

I have setted AutoIt3Wrapper.ini:

[Autoit]

aut2exe=c:\mypath\Aut2Exe\Aut2Exe.exe

but AutoIt3Wrapper.exe every prompt me to path Aut2Exe.

How to avoid?

Share this post


Link to post
Share on other sites
Jos

Try using the directives... i want to move away from the INI as this is replaced by the directives and I left it in for backwards compatibility.

Guess I missed something somewhere.

#AutoIt3Wrapper_Aut2Exe=c:\mypath\Aut2Exe\Aut2Exe.exe
Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Ontosy

i want to move away from the INI as this is replaced by the directives and I left it in for backwards compatibility.

Too bad, because it was convenient INI. I have many files to compile with the same parameters and it is terrible to have to include the following directives in each of them. It would be easier to have a configuration file.

Share this post


Link to post
Share on other sites
Ontosy

2.0.3.2 not fixes it.

Share this post


Link to post
Share on other sites
Ontosy

I not use scite.

I run Autoit3Wrapper directly.

Share this post


Link to post
Share on other sites
Jos

Well you will have to given me information so i can look into the issue.

What is the exact commandline you use?

Can you capture the produced stdout information and share it?

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Ontosy

c:\ProgrammiMark\AutoIt3\AutoIt3Wrapper\AutoIt3Wrapper.exe
Process started >>>
+>11:29:39 Starting AutoIt3Wrapper v.2.0.3.2    Environment(Language:0410  Keyboard:00000410  OS:WIN_XP/Service Pack 2  CPU:X64 OS:X86)
! Unable to determine the location of the AutoIt3 program directory!
>Running:(3.3.6.1):C:\ProgrammiMark\AutoIt3\Aut2Exe\Aut2Exe.exe  /in "c:\Documents and Settings\Mark\Impostazioni locali\Temp\aaaa.au3" /out "c:\Documents and Settings\Mark\Impostazioni locali\Temp\aaaa.exe" /nopack /icon "c:\ProgrammiMark\AutoIt3\Mark\Mark.ico" /comp 2
+>11:30:04 Aut2exe.exe ended.rc:0
+>11:30:04 Created program:c:\Documents and Settings\Mark\Impostazioni locali\Temp\aaaa.exe
<<< Process finished.
================ READY ================

[Autoit]
aut2exe=c:\ProgrammiMark\AutoIt3\Aut2Exe\Aut2Exe.exe
Icon="c:\ProgrammiMark\AutoIt3\Mark\Sapi5.ico"
OutfileType=
Compression=9
PassPhrase=
Allow_Decompile=0
UseUpx=0
UseAnsi=

command line that i use:

AutoIt3Wrapper.exe
Edited by Ontosy

Share this post


Link to post
Share on other sites
Ontosy

Only AutoIt3Wrapper.exe every prompt me to path Aut2Exe, not other. Icon is fine.

Share this post


Link to post
Share on other sites
Ontosy

I have already written that use only

AutoIt3Wrapper.exe

Then wait for the message to select the file AU3

but then it also makes me choose the Aut2Exe path present in AutoIt3Wrapper.ini

Share this post


Link to post
Share on other sites
Jos

ahhh.. ok it didn't dawn on me that you were simply running AutoIt3Wrapper by itself but thought you were running a batch file.

Given the current Beta a try to see if that solves it for you.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Ontosy

now finally it works! :D

Do it is possible to change the path absolute in ini in relative to make portable application?

instead of:

aut2exe=c:\alfa\AutoIt3\Aut2Exe\Aut2exe.exe

Icon="c:\alfa\AutoIt3\prg\Sapi5.ico"

aut2exe=..\Aut2exe.exe

Icon="..\Sapi5.ico"

?

ty :oops:

Share this post


Link to post
Share on other sites
Jos

I am not going to work on adding or modifying code using the INI. Did this one because I believed it was a bug.

You really need to start to use #AutoIt3Wrapper directives in your scripts to make your life easier!

I am nearly done with an AutoIt3Wrapper version and SciTE setup that will run without any Registry setting allowing it to run without installing it.

It will however obviously expect a given directory structure.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Ontosy

[Res] section in AutoIt3Wrapper.ini is processed only if have least a directive in the au3 source file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×