Sign in to follow this  
Followers 0
ModemJunki

Action center submenu? Need a more elegant solution

4 posts in this topic

Hi all,

I have a script that makes ActionCenter settings on deploy of system. I can open action center, maximize the window (all target systems have same size display), mouse click the coords for the Action Center Settings link, and proceed from there to click the needed controls.

So really, the script works. But it looks clumsy. I don't really want to put a splash screen because I want the person doing the system install to see what is going on, espceially now as I develop and have other test.

But I can't figure out why I have to use a mouse click - AutoITWindowInfo never shows the controls for the menu on the left pane of the Action Center.

Is there a way to find the CLSID of the submenu (I didn't find in any lists readily available) or is it a lost cause, and I should keep the maximize function instead?

Share this post


Link to post
Share on other sites



Unless I am reading it wrong, it sounds like you're trying to set options in the Action Center upon deployment of a new system. Rather than mousemove, I would suggest looking into making your changes programmatically. Most of the settings are stored in the registry under "HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionAction Center". If you Google "change action center settings registry" there are several MS articles that show you how to set different options. This should be a lot cleaner (and faster!) than manually opening the window.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0