Sign in to follow this  
Followers 0
kylomas

Beta Installed Incorrectly

21 posts in this topic

#1 ·  Posted (edited)

Hi,

I installed the 3.3.7.23 version of AutoIT. I ran the "Toggle Au3 Beta" and the msgbox indicated a switch. When I run

msgbox(0,'',@autoitversion)
from SCITE it shows 3.3.6.1.

Do I need to change something else to activate Beta?

Also, do I need to copy new Sqlite mod and .au3 files?

Thanks,

kylomas

Edit: spelling

Edit2: additional info - when I "ToggleAu3 Beta" and invoke a script outside of SCITE, I get SQLite.dll not found. When I run the script under SCITE, it runs fine.

Edited by kylomas

Forum Rules         Procedure for posting code

"I like pigs.  Dogs look up to us.  Cats look down on us.  Pigs treat us as equals."

- Sir Winston Churchill

Share this post


Link to post
Share on other sites



When you run a script from SciTE and you want to use the Beta you need to use ALT-F5 instead of F5 to run it.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

BrewmanNH, Thanks for the prompt reply. I finally figured that much out. I have something setup wrong, however. I am running one of my scripts from a desktop shortcut pointing to the script source. That script uses slqite and issues the error "sqlite.dll not found". I tried copying "sqlite.dll.au3" to the beta folder (overlaying the one that was there) to no avail. Thanks, kylomas

edit:spelling

Edited by kylomas

Forum Rules         Procedure for posting code

"I like pigs.  Dogs look up to us.  Cats look down on us.  Pigs treat us as equals."

- Sir Winston Churchill

Share this post


Link to post
Share on other sites

You have to extract the dll from that file before you can use it, to do that you need to use #include <sqlite.dll.au3> at the top of the script, it should extract the dll to the script folder. You can also download the latest version of the dll from sqlite's home page. The Beta doesn't include the actual dll any longer in the file, so you have to make sure that the file exists because there's no call in the _SQLite_Startup function to extract it now.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

BremanNH,

Is this a change? I did NOT see that in the script breaking doc...

kylomas

edit: additional info

I have includes for sqlite.dll and slqite.dll.au3...I did NOT get a new copy of sqlite.dll from sqlite.org. Could that be what's wrong?

Edited by kylomas

Forum Rules         Procedure for posting code

"I like pigs.  Dogs look up to us.  Cats look down on us.  Pigs treat us as equals."

- Sir Winston Churchill

Share this post


Link to post
Share on other sites

I saw a mention of it in the chat forum about the latest beta it wasn't mentioned as a script breaking change, but it might be in the future.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

I tried Alt - F5 but it doesnt work. I can run script using F5 but nothing happens when i press Alt - F5. Can you please help. I have AutoIt beta installed and i can see it in C:Program FilesAUtoIt3Beta

Share this post


Link to post
Share on other sites

I tried Alt - F5 but it doesnt work. I can run script using F5 but nothing happens when i press Alt - F5. Can you please help. I have AutoIt beta installed and i can see it in C:Program FilesAUtoIt3Beta

Show the SciTE ouput pane information generated when pressing f5 and when pressing alt+f5.

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I figured the issue i was having with using BETA. I observed that i had 2 instances of AutoIt and SciTE installed....One in program files and other on my Desktop....i didnt realize i was using the desktop version of SciTE.....I have BETA installed only in program files.....I switched to use SciTE which is installed in Program Files and Alt + F5 worked... :) I can see below output after pressing Alt + F5

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:Documents and Settingsp2zoDesktopLHUSTestScriptLHUSPRPCFinalActionScript.au3" /autoit3dir "C:\Program Files\AutoIt3\Beta\" /UserParams

+>14:49:59 Starting AutoIt3Wrapper v.2.0.1.24 Environment(Language:0409 Keyboard:00000409 OS:WIN_XP/Service Pack 3 CPU:X64 OS:X86)

>Running AU3Check (1.54.22.0) from:C:Program FilesAutoIt3Beta

+>14:50:00 AU3Check ended.rc:0

>Running:(3.3.7.23):C:\Program Files\AutoIt3\Beta\autoit3.exe "C:Documents and Settingsp2zoDesktopLHUSTestScriptLHUSPRPCFinalActionScript.au3"

Share this post


Link to post
Share on other sites

Other question i have is....how do i compile a script manually using beta version? Right now i just right click the .au3 file and complie it to form a exe file to run. If i have to do the same thing but use beta instead how do i complie it manually. Sometimes i need to use exe file to run the script instead of running it from SciTE.

@Jos - Sorry for hte other thread....I wont duplicate questions in multiple threads.....Additionally i do search for answer to my issue in existing threads...if i dont find anything i post a new one...

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

I figured the issue i was having with using BETA. I observed that i had 2 instances of AutoIt and SciTE installed....One in program files and other on my Desktop....i didnt realize i was using the desktop version of SciTE.....I have BETA installed only in program files.....I switched to use SciTE which is installed in Program Files and Alt + F5 worked... :) I can see below output after pressing Alt + F5

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:Documents and Settingsp2zoDesktopLHUSTestScriptLHUSPRPCFinalActionScript.au3" /autoit3dir "C:\Program Files\AutoIt3\Beta\" /UserParams

+>14:49:59 Starting AutoIt3Wrapper v.2.0.1.24 Environment(Language:0409 Keyboard:00000409 OS:WIN_XP/Service Pack 3 CPU:X64 OS:X86)

>Running AU3Check (1.54.22.0) from:C:Program FilesAutoIt3Beta

+>14:50:00 AU3Check ended.rc:0

>Running:(3.3.7.23):C:\Program Files\AutoIt3\Beta\autoit3.exe "C:Documents and Settingsp2zoDesktopLHUSTestScriptLHUSPRPCFinalActionScript.au3"

Your value for autoit3dir in au3.properties is wrong and should be

autoit3dir=C:Program FilesAutoIt3

It is important you use the standard install paths used by the standard installers unless you know what you are doing.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

Your value for autoit3dir in au3.properties is wrong and should be

autoit3dir=C:Program FilesAutoIt3

It is important you use the standard install paths used by the standard installers unless you know what you are doing.

Jos

@Jos - i am using AutoIT beta to run the script...using ALT+F5 so i think the autoit3dir is correct to point to /autoit3dir "C:\Program Files\AutoIt3\Beta\" Can you please confirm....

Can you also reply to my last post regarding compiling the file to EXE using BETA.

Edited by sadaphvi

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Compile it from SciTE:

F7 = Compile Prod

Alt+F7 = Compile Beta

Or use the DIrectives.

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#14 ·  Posted (edited)

@Jos - i am using AutoIT beta to run the script...using ALT+F5 so i think the autoit3dir is correct to point to /autoit3dir "C:\Program Files\AutoIt3\Beta\" Can you please confirm....

What is the value i shown in your au3.properties? Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

What is the value i shown in your au3.properties?

# SciTE settings for AutoIt v3

#

# February 26, 2010 - Jos

#

#

# *** Specify here your AutoIt program directory ***

autoit3dir=C:Program FilesAutoIt3

openpath.$(au3)=$(autoit3dir)include

openpath.beta.$(au3)=$(autoit3dir)betainclude

au3=*.au3

filter.au3=AutoIt (au3)|$(au3)|

lexer.$(au3)=au3

Just FYI....I am able to run the scripts successfully using BETA.

Share this post


Link to post
Share on other sites

Just FYI....I am able to run the scripts successfully using BETA.

This looks good. You shopuld be able to run both version by using the right Shortcuts:
  • F1=Help Production
  • F5=Run Production (Will run AU3Check and AutoIt3)
  • Ctrl+F5=Au3Check Production
  • F7=Compile Production (Will run AU3Check and Aut2Exe)
  • Alt+F1=Help Beta
  • Alt+F5=Run Beta (Will run AU3Check and AutoIt3)
  • Alt+Ctrl+F5=Au3Check Beta
  • Alt+F7=Compile Beta (Will run AU3Check and Aut2Exe)

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Compile it from SciTE:

F7 = Compile Prod

Alt+F7 = Compile Beta

Or use the DIrectives.

Thanks so much!! It helps! I also had a look au3.properties files when you mentioned about it and got to know all the different settings....thanks for informing about it....

Alternately I figured we can do a RIGHT CLICK to au3 file then we can select COMPILE WITH OPTIONS and then in the options window we can select AutoIt version as BETA to compile the script to exe.

Share this post


Link to post
Share on other sites

This looks good. You shopuld be able to run both version by using the right Shortcuts:

  • F1=Help Production
  • F5=Run Production (Will run AU3Check and AutoIt3)
  • Ctrl+F5=Au3Check Production
  • F7=Compile Production (Will run AU3Check and Aut2Exe)
  • Alt+F1=Help Beta
  • Alt+F5=Run Beta (Will run AU3Check and AutoIt3)
  • Alt+Ctrl+F5=Au3Check Beta
  • Alt+F7=Compile Beta (Will run AU3Check and Aut2Exe)
Jos

Great!! Thanks so much for your valuable time JOS!! I see that using BETA is as easy as adding ALT to the production options! Thanks again for all your help!!

Share this post


Link to post
Share on other sites

Well... let me give you one other pointer here: Ctrl+1 or SciTE -> Help/SciTE help.

This will open the Helpfile I wrote that contains all info about SciTE and its tools.

Jos :)


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Gentlemen,

Interesting discussion, any insight into the sqlite.dll problem that I am having?

kylomas


Forum Rules         Procedure for posting code

"I like pigs.  Dogs look up to us.  Cats look down on us.  Pigs treat us as equals."

- Sir Winston Churchill

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0