Sign in to follow this  
Followers 0
tarvr

Problems with GUI buttons transparent mode

3 posts in this topic

Hello,

I try to create a menu. I don’t manage to create my buttons in transparent mode. Labels transparent mode is no problem.

Can someone help me with this please?

For testing put a file called “background.bmp” in the same folder as the AU3 script.

Menu.au3

Share this post


Link to post
Share on other sites



It is because GUICtrlSetBkColour doesnt support alpha channels (transparency) as far as I am aware. Try using a label rather than a button, and when the user clicks on that, then you do whatever the button was meant to do.

Share this post


Link to post
Share on other sites

Afaik the problem is the $BS_COMMANDLINK style and the color cannot be set to transparency.

You can use picture controls and send a transparent image (e.g. PNG) to the control and simulate a hover effect.

Br,

UEZ


Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0