Sign in to follow this  
Followers 0
LoWang

SciTE - default tab size and indentation settings

10 posts in this topic

Hello, I enjoy making scripts with very deep cycles, if, switches and other such constructs so I am just used to use only one space as indentation. it saves time and prevents any viewing troubles if someone wanted to open my scripts in different viewer then SciTE. So how can I change the SciTE defaults so it is spaces and not tabs and only one? I found some .properties file and changed "Indent size" to 1, but did not find Tab size there and the settings to use spaces instead of tabs, so now I have to change it whenever I open some au3 file or create a new one.

Thank you for help

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

This settings is not there at all so I added it and it seems to have worked, BUT I need to change the tab size settings also, because it is still 4.

I tried use.tabs.$(au3)=0, but it did not work and actually changed the default value from 4 to 8 :-o

Edited by LoWang

Share this post


Link to post
Share on other sites

OK now it works - tab.size.$(au3)=1

Of course 0 is a nonsense sorry :) Anyway this really should be somewhere in the menu instead of tinkering with files IMHO.

Share this post


Link to post
Share on other sites

(rude word here) it stopped working! Can somebody please tell me why something so simple just can't work??

Now indent size for new files and opened old files is again set to 4!

I attached those settings files so please check it and tell me what did I do wrong in it to make SciTE ignore this. It seems the file is completely being ignored because

#CaretLineBackground

caret.line.back=#FFFED8

also does not have any effect if I understand this settings right...

SciTEGlobal.properties has the same Indentation settings but it also does not have any effect.

Thank you for your patience.

SciTEGlobal.zip

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Sure, caret.line.back works for me anyways. Put those settings that you want to override into your SciTEUser.properties file. So that's 'Options' --> 'Open User Options File'. Also, put them outside of any thing SciTEConfig generates.

Edited by LaCastiglione

Share this post


Link to post
Share on other sites

thank you, now it works again. But don't want me to understand this mess :)

Share this post


Link to post
Share on other sites

I have installed AutoIt on my second pc and wanted to do this change too, but those files are not there at all! It seems that SciTe which is being installed with the AutoIt bundle is somehow stripped of functions, is that right? I did not download the separate package, I just noticed it is there right after AutoIt installation...

Share this post


Link to post
Share on other sites

I have installed AutoIt on my second pc and wanted to do this change too, but those files are not there at all! It seems that SciTe which is being installed with the AutoIt bundle is somehow stripped of functions, is that right? I did not download the separate package, I just noticed it is there right after AutoIt installation...

Correct. The version that comes with the autoit3 installer has basic functionality only with a minimal number of lexers.

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0