Jump to content
Sign in to follow this  

Various Issues with SciTE4AutoIt3

Recommended Posts


I am running v on Win 7 64-bit and I am having some problems. Basically, some things just don't work.


  • F5, F7, Ctrl + F7 works as expected, and I can enter paramaters with Shift + F8, but the parameters don't seem to get used for F5. For example, $CmdLine[0] reports zero.
  • Ctrl+Shift+D doesn't work. Nothing happens when I envoke it.
  • Ctrl+F5 does nothing.
  • Alt+G doesn't work.
I am wondering if maybe the things that aren't working rely on Lua or something and that isn't functioning properly on my system.

Any ideas how to troubleshoot these issues?

Share this post

Link to post
Share on other sites

They all work for me. Try downloading the full version from the downloads page, and see if this solves the problem for you.

  • Like 1

Share this post

Link to post
Share on other sites

They all work for me. Try downloading the full version from the downloads page, and see if this solves the problem for you.

Full version of which? The full version of AutoIt is already installed. Not sure if that is what you meant or something else?

Share this post

Link to post
Share on other sites

I would recommend when it asks you if you wish to install for x86 or x64, just use the x86 installation, even though you are on a 64bit os.


“Hello, ladies, look at your man, now back to me, now back at your man, now back to me. Sadly, he isn’t me, but if he stopped using ladies scented body wash and switched to Old Spice, he could smell like he’s me. Look down, back up, where are you? You’re on a boat with the man your man could smell like. What’s in your hand, back at me. I have it, it’s an oyster with two tickets to that thing you love. Look again, the tickets are now diamonds. Anything is possible when your man smells like Old Spice and not a lady. I’m on a horse.”


Share this post

Link to post
Share on other sites

I would recommend when it asks you if you wish to install for x86 or x64, just use the x86 installation, even though you are on a 64bit os.

Not really related to the OPs issue.

Just install the separate scite4autoit3 installer and See if all is working then.

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
Live for the present,
Dream of the future,
Learn from the past.

Share this post

Link to post
Share on other sites

I first tried uninstalling and reinstalling AutoIt and chose to use x86 by default.

That didn't change anything.

I then downloaded and installed the full version of SciTE linked to here and things... umm... changed. Some things remain broken, others are fixed, and yet things that were working are now broken.


  • F5, F7, and Ctrl + F7 don't do anything, but those actions chosen via menu do.
  • Ctrl+Shift+D now works
  • Shift + F8 no longer invokes the parameters dialog, but I can use the menu to open it, and now the parameters are used when I run the script.
  • F5 invokes an Open File dialog.
  • F6 closes the file open in the editor and starts a new blank file.
  • Shift + F5 does not clear the output pane, but menu item works.
I am totally confused by what is going on. I'm not sure what is causing these issues. The common thing seems to be that shortcut keys don't work as they should. But I am not sure that is the only thing wrong.

UPDATE: Installing the full version of SciTE fixed things. All seems to be working now.

For a moment I thought that I had turned off the function keys (I have a Microsoft 4000 keyboard) and that that might have been the origional problem, but it was not. But, in doing so, I had them off as I first tested with the full version of SciTE and then realized my error.

Thanks for all the help.

P.S. As is my custom, I have made a donation (in this case, to AutoIt) because this issue was resolved by the forums/community. I do so when I get help on FOSS from forums, IRC, etc.

Edited by tinjaw

Share this post

Link to post
Share on other sites

Good to hear it worked. Thanks on behalf of the community and developers for your contribution.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • FrancescoDiMuro
      By FrancescoDiMuro
      Good evening everyone
      I was trying to insert function header to the functions of my script, but, in the SciTE console, this appears:
      Function or struct definition not found, unable to insert header. @Jos Any suggestion?
      Thanks in advance.

      Best Regards.
    • cheeroke
      By cheeroke
      Hi I am not sure how to call it properly, but for those of you who use SciTE, when you typing built in function and about to pass parameters to it you can see popup with all the ones which can be passed.
      Question: how to create something like that for my own functions?
    • therks
      By therks
      Does SciTE have string or number ids for the recent file menu items?
      I was hoping to add shortcuts (using the user.shortcuts properties) to the most recent item, but the documentation doesn't list any id's for those items (unless I overlooked?).
      Also, did anyone else notice that the index listing for the SciTE doc doesn't work properly?
      It appears it's linking to this: mk:@MSITStore:C:\Program%20Files\AutoIt3\SciTE\Scite4AutoIt3.chm::/SciTEDocumentation.html
      When it should be this? mk:@MSITStore:C:\Program%20Files\AutoIt3\SciTE\Scite4AutoIt3.chm::/Scitedoc/SciTEDoc.html
    • BrewManNH
      By BrewManNH
      I was looking for a toolbar modification for SciTE and I was checking various versions of SciTE that were available on the internet. They all had some problems for how I wanted to use the editor, so I looked here to see if there were any toolbar modifications for Scite. I found one very old script by YogiBear (Volly) from 2006 that looked promising, though there were issues with it. I decided to see what I could do to modify this script, and make some improvements to it if possible. This script is the result of that work.

      It's not perfect and definitely could use some tweaking, but I thought that it had matured enough, and was mostly stable enough to release the updated version.

      Version 2.0.1
      Minor update to remove all the old Obfuscator directives and replaced them with #Au3Stripper directives instead. I also corrected a minor bug that only showed up for me on one computer I tried this on, and caused the tool bar to crash for others as well.
      SciTE toolbar version 2.0
      Changed the settings values to use constants instead of 'magic numbers' The icons on the toolbar weren't lining up with the separator characters or with the toolbar GUI because they weren't set with the resize setting for the icons, only for the separators. Changed to using arrays for everything, it makes it a lot easier to loop through the controls Added a line to use an alternate path to the SciTE program, so you can start it using, for example, the portable version instead of installed version for those that don't install AutoIt and/or SciTE4AutoIt3. It will accept a commmand line parameter that points to the SciTE executable. Removed a lot of Global variables by moving the GUI creation and monitoring to the Main function and passing variables from it. I embedded the icon files into the script so that there isn't a separate download of the icon files used here. Saves download time and makes the package smaller. Modification of tools is easier because the icon names, tooltip text, and SciTE command codes are saved in the INI file upon first start up. These can be modified after the script has been run once, even after it's been compiled, by changing the ini file information, you can modify this script to automate it, or you can change it manually in any text editor. The icon files are now using, in just my opinion, better looking icons, after all it's been 7 years and icon files have matured. I have included a file with all of the constants that SciTE uses for its menu commands which comes from the SciTE source file "scite.h", so you can use this file to help you modify the commands that the toolbar works with, by figuring out what each of these values represent in SciTE. The core of the script is pretty much the same, I've just fixed a couple of issues that it had, tweaked a few things, added some new functionality and "prettied" it up a bit.

      If anyone has any suggestions as to improvements, bugs/bugfixes, etc. please let me know.

    • Aguilucho
      By Aguilucho
      Greetings to the AutoIt community.
      I hope that nobody considers my question insulting but I searched 'SciTEConfig.exe' and I did not find it anywhere;
      although it is mentioned, it seems like a myth, I can not see if it exists.
      On the other hand, I have downloaded the compressed archive (from ... autoit-script-editor/downloads) 'SciTEConfig_Source.zip'
      Does not contain any .exe either but does have a 'SciteConfig.au3' which, I suppose, has replaced the .exe because on the internet I only find it as malware.
      My problem is: My applications to unzip .zip archives, they can see what files SciTEConfig_Source.zip have but they can not unzip it: 'Unknown method' says WinRar.
          I have downloaded it again, in case it had been damaged but the result is always the same.

      My question is: Is the archive 'SciTEConfig_Source.zip' damaged or does it have any other method of compression?
      I need it to learn how to configure SciTE (lite).
      Thankful to the developers of AutoIt and to the community.