Sign in to follow this  
Followers 0
thebestnewbie

Problem with a click on a input submit type button

3 posts in this topic

#1 ·  Posted (edited)

Hi,

I've got some problem to properly hit that button.

HTML :

<tr>

<td colspan=3 align=center><input type=submit value="Send"></td>

</tr>

Code I've got so far :

$oTags = _IETagNameGetCollection($oIE, "input")

For $oTag In $oTags

If $oTag.Value == "Send" Then

_IEAction($oTag, "click")

_IELoadWait($oIE)

EndIf

Next

If you got any idea please share with me. I don't seems to find any place it tells me all the element I can get from $oTag.xxx , Maybe there is a $oTag.Type I can use and put submit in it.

Thanks to everyone who post in this thread.

Edited by thebestnewbie

Share this post


Link to post
Share on other sites



You don't describe what happens with your code.

A blind suggestion... replace

If $oTag.Value == "Send" Then

With:

If String($oTag.Value) == "Send" Then

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thanks Dale,

Sorry for the lack of details.

Actually I debugged it with some MsgBox.

The loop was crashing because the last Tag return by the Collection method is : Null.

So I just added your syntax and an ExitLoop after the end and it made it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0