Jump to content
Sign in to follow this  
Stumpii

Autotravel Move for WoW

Recommended Posts

There are good instructions on the operation and use of AT in the addon zip file and on the AT and AT Rez sections on the Curse site. I suggest you look through those to find out what the addon can do and how to use it. They have forums to ask about the operation of the addon if you need extra info. I would like to limit this forum to strictly the operation of the Autotravel Move program.

<{POST_SNAPBACK}>

k, srry, ty again

Share this post


Link to post
Share on other sites

k, srry, ty again

<{POST_SNAPBACK}>

omg, this is a pain, im in the game, i press the "move" button once, me guy just keeps running forward, i press it again and he just spins in circles. lol, whats up?

Share this post


Link to post
Share on other sites

omg, this is a pain, im in the game, i press the "move" button once, me guy just keeps running forward, i press it again and he just spins in circles. lol, whats up?

<{POST_SNAPBACK}>

:) ok, tis easy

you dont press the key u bind to "move" u press the "pause/resume" button.

this then causes Stumpiis script to repeatedly press the move key.

auto travel ressurection requires you to press the move key continually while using it.

so this script gets rid of that problem and does it for you.

Share this post


Link to post
Share on other sites

:) ok, tis easy

you dont press the key u bind to "move" u press the "pause/resume" button.

this then causes Stumpiis script to repeatedly press the move key.

auto travel ressurection requires you to press the move key continually while using it.

so this script gets rid of that problem and does it for you.

<{POST_SNAPBACK}>

k, i get it, but everytime i press the pause/resume button nothing happens.

Share this post


Link to post
Share on other sites

:) ok, tis easy

you dont press the key u bind to "move" u press the "pause/resume" button.

this then causes Stumpiis script to repeatedly press the move key.

auto travel ressurection requires you to press the move key continually while using it.

so this script gets rid of that problem and does it for you.

<{POST_SNAPBACK}>

also, why does it only let me go to a point that is in like a 50 yard area arround me? can i change this?

Share this post


Link to post
Share on other sites
Guest madrunner

Hi all,

Well done firstly. Efforts like these keep me playing WoW.

A few questions:

1. Is there a better key one should bind that works better than others? I've heard people talk about using the down-arrow because it does not interfer with tying, but doesn't that mean I can no longer use the down arrow to back up (using "s" isn't possible when typing)? Is there a key that does not interfer with typing AND does not interfer with movement?

2. Can I assume that there will be no possibility of unfocused key-press transmission? Often I Alt-Tab away while auto-travelling in order to look something up, etc.

Thanks

Share this post


Link to post
Share on other sites

also, why does it only let me go to a point that is in like a 50 yard area arround me? can i change this?

<{POST_SNAPBACK}>

rampagerolph, sounds like you haven't set up the path's correctly but this isn't the AutoTravel thread, this is for the program that just punch a key for you. Head over to curse-gaming.com or simular to ask for question about AT.

Share this post


Link to post
Share on other sites

Hi all,

Well done firstly.  Efforts like these keep me playing WoW.

A few questions:

1.  Is there a better key one should bind that works better than others?  I've heard people talk about using the down-arrow because it does not interfer with tying, but doesn't that mean I can no longer use the down arrow to back up (using "s" isn't possible when typing)?  Is there a key that does not interfer with typing AND does not interfer with movement?

2.  Can I assume that there will be no possibility of unfocused key-press transmission?  Often I Alt-Tab away while auto-travelling in order to look something up, etc.

Thanks

<{POST_SNAPBACK}>

1. You can pick any key you like, I use UP for the mashing and PAUSE for the toggle, that way I can still use down to back up or pause the movement for a sec while typing. Just play around with different keys and see if you find one that works for you.

2. The key masher shouldn't have any problems if you Alt-Tab, it sends it's commands to the WoW window even if it isn't in focus.

Share this post


Link to post
Share on other sites
Guest kizatz

:) ok, tis easy

you dont press the key u bind to "move" u press the "pause/resume" button.

this then causes Stumpiis script to repeatedly press the move key.

auto travel ressurection requires you to press the move key continually while using it.

so this script gets rid of that problem and does it for you.

<{POST_SNAPBACK}>

Ok here is my problem. I want to use the \ key to start my char on his way. My pause button is delete.

I have set Move! to \ and AT Resume/Pause to delete. I open the script and it prompts me with what buttons do what. What do I pick? No matter what I try I have to keep pushing \ to go anywhere. I have everything else figured out but the last step :evil: Please send some help my way.

Share this post


Link to post
Share on other sites

Ok here is my problem. I want to use the \ key to start my char on his way. My pause button is delete.

I have set Move! to \ and AT Resume/Pause to delete. I open the script and it prompts me with what buttons do what. What do I pick? No matter what I try I have to keep pushing \ to go anywhere. I have everything else figured out but the last step  :)  Please send some help my way.

<{POST_SNAPBACK}>

Okay, I see the problem. The script is designed for 'special' keys, not 'regular' keys (A-Z, 0-9). The special keys require {} around them. To fix this find the following in the script:

If $CurrentlyRunning = 1 Then
        ControlSend($Title, "", "", "{" & $keybutton & "}")
    EndIf

and replace it with:

If $CurrentlyRunning = 1 Then
        ControlSend($Title, "", "", $keybutton )
    EndIf

I will have to think of some other way of doing this that will allow both without breaking it for all the other users!


“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Share this post


Link to post
Share on other sites

hmm something like this might work...

...
If $CurrentlyRunning = 1 Then
  If StringLen($Keybutton) > 1 Then
    ControlSend($Title, "", "",  "{" & $Keybutton & "}")
  Else
    ControlSend($Title, "", "",  $Keybutton)
  EndIf
EndIf
...

since all regular keys a-z and such only have a length of one while the "commands" are longer, might be a flawed idea though...

Share this post


Link to post
Share on other sites

hmm something like this might work...

...
If $CurrentlyRunning = 1 Then
  If StringLen($Keybutton) > 1 Then
    ControlSend($Title, "", "",  "{" & $Keybutton & "}")
  Else
    ControlSend($Title, "", "",  $Keybutton)
  EndIf
EndIf
...

since all regular keys a-z and such only have a length of one while the "commands" are longer, might be a flawed idea though...

<{POST_SNAPBACK}>

Thanks h8no1. It should work as the only single keys that require curly brackets are #+^{}. These all require SHIFT also, so could not be used for AT.

I have updated the code accordingly and posted it as v1.3 at the start of this thread.


“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Share this post


Link to post
Share on other sites
Guest kizatz

Thanks h8no1. It should work as the only single keys that require curly brackets are #+^{}. These all require SHIFT also, so could not be used for AT.

I have updated the code accordingly and posted it as v1.3 at the start of this thread.

<{POST_SNAPBACK}>

:) Thanks! I kept playing with it and got it to work. I am at work right now so I cant paste what I did, but I also changed something and wanted to make sure it was OK. There is a spot for Random 400,900 (I think) that I changed to 50,100. I was looking for a way to get it to mash faster. It seems to have worked, as my char no longer makes any circles, or even looks like a bot. And the way I got the keys to work in the first place is just put \ for mash and delete for trigger... it worked w/out your new coding. Just wanted to thank you for being so helpful and making WoW a (yet again) enjoyable game! (I actually think Bliz should PAY the original designer for this and integrate it for long travels... but they would probobly try to sell it as an expansion since nothing is free w/ them) :evil:

Share this post


Link to post
Share on other sites

Okay, well on my game i entered mash as ; and pause/resume as '. well instead of repeatedly hitting the mash button it is repeatedly hitting my pause/resume button. easy solution right? go into my key bingings and switch them arround so that now mash is ' and pause/resume is ;. well i tried that, it still keeps pauseing my walk. whats up?

Share this post


Link to post
Share on other sites

Okay, well on my game i entered mash as ; and pause/resume as '.  well instead of repeatedly hitting the mash button it is repeatedly hitting my pause/resume button. easy solution right? go into my key bingings and switch them arround so that now mash is ' and pause/resume is ;. well i tried that, it still keeps pauseing my walk. whats up?

<{POST_SNAPBACK}>

I don't know what the problem is so, first, make sure that you are using the latest version of my script. Second, run WoW without my program and press the Move! key manually and make sure that it AT Rez works fine. This will rule out any other weirdness that you may be experiencing that is unrelarted to AT Move.

“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Share this post


Link to post
Share on other sites

kizatz if you have something like Random(400,900) in your code I think you should grab the latest version from Stumpii on the first page, it is changed so you can set those values from the gui.

But too answer your question, yup altering those values should work fine. I use 50/70.

Share this post


Link to post
Share on other sites

To all:

I have now also included the script 'AT Randomiser' to randomly change the exe filename of the AT Move program to stop those snooping Blizz people ph34r.gif . For the randomiser to work, the AT Move program must be compiled.

Attached to first post as usual.


“Give a man a script; you have helped him for today. Teach a man to script; and you will not have to hear him whine for help.”AutoIt4UE - Custom AutoIt toolbar and wordfile for UltraEdit/UEStudio users.AutoIt Graphical Debugger - A graphical debugger for AutoIt.SimMetrics COM Wrapper - Calculate string similarity.

Share this post


Link to post
Share on other sites
Guest Joker

Hi all,

i am an italian new user. The script is nice and AutoIt is very cool (i discovered it yesterday).

I tried to play with the two scripts above and founded a couple of little improvements.

I have recently reinstalled the PC operating system and i am using Wow creating link manually from old installation directory. I discovered that in registry only a key is present named "InstallPath". The GamePath key is not present. I think the client recreate that key only, when launched.

Thus, i modified the script as following:

(start from line 162)

; Check where WoW is installed, from registry
$WoWPath = RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Blizzard Entertainment\World of Warcraft", "InstallPath")
; Check if the reg entry existed
If $WoWPath <> "" Then
     Run($WoWPath & "\WoW.exe", $WoWPath)
Else
     MsgBox(48, "Autotravel Move", "WoW has not been detected. If WoW is installed, please start it manually.")
EndIf

I see that the string "\WoW.exe" it is not very clean but i could test both key as follow:

; Check where WoW is installed, from registry
$WoWInstallPath = RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Blizzard Entertainment\World of Warcraft", "InstallPath")
$WoWGamePath = RegRead("HKEY_LOCAL_MACHINE\SOFTWARE\Blizzard Entertainment\World of Warcraft", "GamePath")
; Check if the reg entry existed
If $WoWGamePath <> "" And $WoWInstallPath <> "" Then
     Run($WoWGamePath, $WoWInstallPath)
ElseIf $WoWInstallPath <> "" Then
     Run($WoWInstallPath & "\WoW.exe", $WoWInstallPath)
Else
     MsgBox(48, "Autotravel Move", "WoW has not been detected. If WoW is installed, please start it manually.")
EndIf

I have tested only the first choice and writed the second directly in this post, but i think after a little test the second it is the best.

I also founded a little error in the randomizer script al line 13:

$Filename = "Autotravel Mover*.exe"

changed in:

$Filename = "Autotravel_Mover*.exe"

Thanks to all and excuse me for bad english

bye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...