Sign in to follow this  
Followers 0
Champak

_IEImgGetCollection problem

5 posts in this topic

Does _IEImgGetCollection work on the whole page as an object, or can I look in a specific object, say TR and get the images in that? Eveytime I use this I seem to only get it to work for the whole page even when I look inside a TR or TD that I know has images. I cant use index on the whole page because it varies. I am unable to show code at this moment. Thanks.

Share this post


Link to post
Share on other sites



From the helpfile:

Returns a collection object variable representing the IMG tags in the document or a single image by index.

If you want to scope your search, use _IETagnameGetCollection with IMG:

Returns a collection object of all elements in the object with the specified TagName or a single element by index.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

I read the help file and I dont fully understand it. And the reason I didnt use _IETagnameGetCollection is because I actually want the images file name, or the url (which i can parse to get what I need) if possible. So my original question still stands please, or can I get the info I need with _IETagnameGetCollection?

Share this post


Link to post
Share on other sites

I think you're confused.

The collection object returned by _IETagnameGetCollection is the same as what is returned by _IEImgGetCollection except that _IEImgGetCollection includes image maps as well.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Perfect, thanks for pointing that out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0