Jump to content
Sign in to follow this  
EricF

RunAs() doesn't function with network login

Recommended Posts

EricF

Hi, I'm testing the RunAs() function. I created 2 scripts for that.

Launcher.exe :

Dim $param = $CmdLine[1];
Dim $user = IniRead("_launcher.ini", "general", "user", 0)
Dim $pass = IniRead("_launcher.ini", "general", "pass", 0)
Dim $domain = IniRead("_launcher.ini", "general", "domain", 0)
Dim $flag = IniRead("_launcher.ini", "general", "flag", 0)
Dim $runas

MsgBox(0, "test", "user : " & $user & " /domaine : " & $domain & " /pass : " & $pass & " /flag : " & $flag & " /param : " & $param)
$runas = RunAs($user, $domain, $pass, $flag, $param)

Test.exe :

MsgBox(0, "", "Username : " & @UserName & " - DNSDomain : " & @LogonDNSDomain & " - Domain : " & @LogonDomain)

If i launch test.exe, it shows the current loggin informations. If i launch "c:pathlauncher.exe c:pathTest.exe" with a network user, I have first a msgbox from launcher.exe that show the correct informations, but not the msgbox from Test.exe. I tried lots of possibilities, even changing the flag number, but the problem is always here. If I try the same scripts on my computer with local admin account, it's ok. WTF ? What flag number to use ?

Share this post


Link to post
Share on other sites
BrewManNH

There's only 4 flags, try them all and see which one gives you the results you're looking for.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
EricF

lol I used the 3 first, and the result is the same.

Share this post


Link to post
Share on other sites
EricF

I modified my scripts. It returns an error 3 when I try to launch a program using a network drive. If I launch the same with an UNC path, it's okazy. Do u know a problem in autoit with the network drives ? The network is available, and a FileExists() on it return true.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×