Jump to content
Sign in to follow this  
EndFunc

Run, RunWait... Run anything is not working for cmdline

Recommended Posts

EndFunc

I've been trying to run an external program via the command line and it's not working. I've run many things using Run, Runwait, _RunDos etc and typically don't have a problem.

I'm trying to run this command for Broadcom Nic and it won't work.

C:WindowsSystem32baspscfg.exe -name server1 -type 0 -pnic 01:00.0 -snic 01:00.1 -vname VLAN" & $vlan & " -vid " & $vlan & " -ip " &  $ip & " -smask " & $Mask & " -gw " & $gateway & " -dns " & $adns[0] & " -dns " & $adns[1]

And keeps coming back as

'C:\Windows\System32\baspscfg.exe' is not recognized as an internal or external command,

operable program or batch file.

Yes, the command is there and in the path. the exact line there will work if I substitute the variables for values and paste it in a command window. Also a batch file that I call using RunWait with NO variables and the actual values will NOT work either.

But if I double click the bat file to run it, it works flawlessly. I've also tried @ComSpec as noted in Run commands and it says the same error.

Why is Run not working with cmdline?

Edited by EndFunc

EndFuncAutoIt is the shiznit. I love it.

Share this post


Link to post
Share on other sites
BrewManNH

Are you using a 64 bit windows version? Try the suggestions for how to get around that if you are.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
EndFunc

Are you using a 64 bit windows version? Try the suggestions for how to get around that if you are.

Ah yes. I had no idea that was an issue. I've been running x64 and haven't been having any issues. I run things all the time and haven't noticed a problem. That appears to be it.

Thanks for the helpful direction. ;)


EndFuncAutoIt is the shiznit. I love it.

Share this post


Link to post
Share on other sites
Rofellos

The '\' are missing in 'C:\Windows\System32\baspscfg.exe'

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.