Sign in to follow this  
Followers 0
jaberwacky

[SOLVED] Windows 7, compiling, and make ...

5 posts in this topic

#1 ·  Posted (edited)

I'm trying to compile a version of SciTE for LSL (Linden Scripting Language). The readme in the SciTE directory says to do this to compile SciTE:

cd scintilla\win32

nmake -f scintilla.mak

However, I'm seeing a "'nmake' is not recognized as an internal or external command, operable program or batch file." error. I have installed Visual Studio Express 2010. I'm using Windows 7 x64 pro. Does any body have any ideas as to why I'm seeing this message? Do I need to install CygWin?

Edit: I used the visual studio command promt and unless I did that wrong (likely) then that didn't work either.

Edit: When I type: C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC>nmake -f "D:\Source Code\LSL\SciTE-LSL\scite175-lsl\scintilla\win32\scintilla.mak" I receive this: "NMAKE : fatal error U1073: don't know how to make '../src/AutoComplete.cxx'"

Edited by LaCastiglione

Share this post


Link to post
Share on other sites



Using the Visual Studio Command Prompt is correct. The only thing I can suggest is set your working directory to scintillawin32 before you use nmake /F scintilla.mak. Obviously switch to the appropriate SciTE directory as well before you make it.

Share this post


Link to post
Share on other sites

This is the entire screen from the cmd prompt:

Setting environment for using Microsoft Visual Studio 2010 x86 tools.

C:Program Files (x86)Microsoft Visual Studio 10.0VC>cd d:Source CodeLSLSci
TE-LSLscite175-lslscintillawin32

C:Program Files (x86)Microsoft Visual Studio 10.0VC>nmake /F scintilla.mak

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

NMAKE : fatal error U1052: file 'scintilla.mak' not found
Stop.

C:Program Files (x86)Microsoft Visual Studio 10.0VC>

Share this post


Link to post
Share on other sites

No shit, noob. You forgot /D on your cd command to tell it to change drives. You're still in the VS10 working directory.

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Oh wow! Well, I deserved that one I guess. Anyways, thank you for your help I think this is going to do it!

Edit: I may actually have to take this a SciTE help forum because I'm getting some weird compilation errors.

Edit: SUCCESS! I found out that the Opt:NOWIN98 is no longer supported in VS2010 and so I removed that from the make and it compiled! Thank you so much for your help Valik.

SQUEEALLLL! I'm so happy. First time I ever compiled anything major. Thanks again!

Edited by LaCastiglione

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0