Sign in to follow this  
Followers 0
mickeyf

Input changes within a Virtual Machine

2 posts in this topic

hey guys.

I've been trying to use an Autoit script that I wrote within a Win7 Virtual machine.

The same script runs smoothly on my PC.

But the second I ran it within the VM, all sorts of things happened:

  • Au3Recorder wouldn't start (first because it was missing msvcr100.dll and then because the app couldn't start correctly (0xc000007b)).
  • Inputs were changed before injected to the VM. For example, when the script Sends the word "https://", the IExplorer withing the VM receives "htps;//".
  • some functions don't work at times, but work at other times. For example, when the script strokes WinKey, start menu does not always open.
I have tried updating the Windows7 and use all sorts of patches and suggestions from all over the web, to no success.

Does anyone know what's this all about?

Sorry if i'm not following the forum protocol or am not specific enough. it's my first time here...

Thank you so much!

Mickey

Share this post


Link to post
Share on other sites



Hi, mickeyf, welcome to the forum. Unfortunately, without seeing your code it is a little difficult to determine the problem. I, for one, use about a half dozen XP and Win7 VMs on a daily basis for testing scripts, but cannot say I have seen the issues you are reporting. If you could post a short reproducer script, as well as let us know what VM technology you're using (VMWare, VirtualBox, etc.) we can attempt to assist.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0