Sign in to follow this  
Followers 0
Guest SqeezyCheez

XP Unnatended Help

3 posts in this topic

#1 ·  Posted (edited)

RUN("F:\NFORCE2\setup.exe")

WinWaitActive("NVIDIA Windows nForce Drivers", "Welcome to the InstallShield")
Send("!n")

WinWaitActive("NVIDIA Windows nForce Drivers", "LICENSE FOR CUSTOMER")
Send("!y")

WinWaitActive("NVIDIA Windows nForce Drivers", "Select the features")
Send("!n")

WinWaitActive("NVIDIA Windows nForce Drivers", "Please review the")
Send("!n")

WinWaitActive("Install NVIDIA IDE SW driver?", "Do you want to install the NVIDIA IDE SW driver?")
Send("!y")

WinWaitActive("NVIDIA Windows nForce Drivers", "Yes, I want to restart my computer now")
Send("{DOWN}")
Send("{ENTER}")

I got it to work fine... but how do I go about making this run during a clean install of Windows XP SP2?

For [GuiRunOnce], you can place them in any folder in the $OEM$ Distribution folders. For example, if you place batch_file.cmd in C:\XPCD\$OEM$\$1\install\ then you would insert this path under [GuiRunOnce] in winnt.sif, like so:

[GuiRunOnce]

%systemdrive%\install\batch_file.cmd

So would I just stick the .au3 as a compiled .exe in the "$OEM$\$1\" directory on the XPCD and then add "%systemdrive%\<blah>.exe" at the bottom of the winnt.sif file? Would that work fine? Or should it be something like "%CDROM%\<blah>.exe"? Edited by SqeezyCheez

Share this post


Link to post
Share on other sites



Is it no "silent setting" for install this drivers ?

Do you 've try with parameters /s or /silent ??

...


----------------------GroumphyMore information about me [Fr]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0