Sign in to follow this  
Followers 0
Toranga

wtf koda formdesigner

4 posts in this topic

The koda form designer is bugged for me

I have spent 2 day´s googling the hell out of this problem but i have not found any solution to it.

win764b pro koda form designer 1.7.3

i have 3 monitors the one on the right is set as my primary monitor. when i open koda formdesigner it opens there, while there if i try to access options ctrl+k it opens somewhere off screen and the program is stuck in a loop waiting for my input on the options screen which is nowhere to be found i press enter which triggers the cancel button on the options screen and i can interact with koda formsdesigner again.

If i move the koda formdesigner gui to the middle screen i can open options and it appears on my middle screen, which is interesting.

But generate code opens nowhere i have tried moving the koda forms designer on all screens and opening it and it doesn´t work.

Anyone got some input on this before i throw my 3rd monitor in the ocean.

Share this post


Link to post
Share on other sites



Some time ago I worked on similar multimonitor problem at our customrs's PC in other application.

I heard about problems with some applications on multimonitor computers where primary monitor is not that left/top most one.

Try to change your monitor configuration to left/top (virtual) monitor to be the primary one if problem dissapear.

I know this is not fix just advice for workaround.

Share this post


Link to post
Share on other sites

Yeah it works. I ended on trying it. I didn´t want to do it cause it screwes upp my awesome system of arranging all the icons on different screens.

But yeah you are the man.

Share this post


Link to post
Share on other sites

I ran into this same issue today. I am using a laptop with a docking bay and a usb monitor adapter. The laptop does not like the primary monitor to be either the bay or the usb interface. I resorted to a technique I have used before to move a previously unreachable window to a monitor I could find. First, I enumerated all the windows with

#include <process.au3>
#include <array.au3>

$a_windows = WinList()
_ArrayDisplay($a_windows)

Then I looked through the list after selecting the "Generate Form Code" and found the window I was looking for. The title is "Code", so I just added the winmove and presto, I can see the window now. PITA, but it works.

#include <process.au3>
#include <array.au3>

$a_windows = WinList()
_ArrayDisplay($a_windows)

WinMove("Code","",60,60)

I know this was caused when I moved the window when the computer was only attached to one monitor. If I disconnect the monitors, I can see part of the code window hanging off the side of the screen. I think I looked into this before and found a registry setting that retains the last open position of the window, but am unable to find it at the moment, so this works in a pinch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0