Sign in to follow this  
Followers 0
AutoTron

Script stopping :(

4 posts in this topic

#Include <FF.au3>

_FFConnect(Default, Default)
_FFAction("Print")
ControlClick("Print", "", "Button10")
_FFDisconnect()
MsgBox(64, "", "Disconnected from FireFox!")

After the print box comes up, the ControlClick is supposed to click 'OK' and the script should be on its way. But the script is stopping after the _FFAction("Print").

I tested the ControlClick by itself by manually opening a print box and executing only the ControlClick and it works just fine.

Please Help!

Share this post


Link to post
Share on other sites



Does _ffaction have an exit code?

Is the script getting stuck, or just exiting?

If it is exiting, what is the error that scite reports?

If it is stuck in a loop, have your tried AutoItSetOption('TrayIconDebug',1)?

Share this post


Link to post
Share on other sites

It is getting stuck. When I press 'Cancel' in the print box, the script continues and the message box pops up.

Where should I put AutoItSetOption('TrayIconDebug',1)?

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Try putting a small Sleep() between _FFAction and ControlClick. A value of 100 should be sufficient, maybe as low as 10, maybe as high as 500.

edit: maybe WinWaitActive() instead of Sleep()..

Edited by somdcomputerguy

- Bruce /*somdcomputerguy */  If you change the way you look at things, the things you look at change.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0