Sign in to follow this  
Followers 0
layer

Server -- Clients cannot connect

8 posts in this topic

Hey guys ... ,

I was just trying Larry's TCP example... I mean I've tried it before, and I could never get clients to connect... But I didn't care back then. So when I run it, and give my cousin my @IpAddress1 and tell him to connect, he cannot. And if I try to make a Counter-Strike dedicated server, nobody out of my network can connect. And when I'm AIM, I cannot make a "Direct Connection" with anyone, I have to ask them to do it... As you can see, I'm missing out on a lot of features, and I'd like to utilize them !

I'm running a Windows XP Home Edition, SP2, with Windows Firewall, and AV's firewall ...

Is any other info needed ?

Any suggestions ? :whistle:

I'd really appreciate it !

Thanks :dance:


FootbaG

Share this post


Link to post
Share on other sites



if you turn off the firewalls, does any of that stuff work?

how are you connected to the internet?

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Sorry, gonna have to get back to you on this one, I need someone to test it with... But I don't know how to disable AV's firewall... But I know how to disable Windows firewall. So we'll see...

Thanks :whistle:

Edited by layer

FootbaG

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Errmmm... I was reading, and it said, if you're behind a router or fire wall you need to forward the port you will be using (27015)... Now I am behind a router... Sooo... I remeber a site to port forward, but I can't remember it... Any ideas? Is this what I'm looking for?

Thanks

EDIT: Ehh, I just used gametiger.com and searched my IP and no results were found (I had a steam dedicated server running..) ... With my firewall disabled, so it must be this port forwarding thing... Ideas? :whistle:

Thanks!

Edited by layer

FootbaG

Share this post


Link to post
Share on other sites

Get the manual to your game, look up the ports that need to be forwarded.

Get the manual to your router, look up port forwarding. Note - Port forwarding doesn't actually need to be done when behind a true router, just when behind a NAT router. If your PC has a public IP, then you probably don't need port forwarding.

Get the manual to your firewall, look up how to open these ports.

Share this post


Link to post
Share on other sites

generally routers have ip address's of 192.168.0.1 or some other iteration of 192.168.X.1

you can find your router via the ipconfig command in the console

the router is acting as your gateway so the gateway ip is the ip you want to use to connect to your router

http://yourroutersiphere

you need to know your username and password to access the router they generall default to admin/administrator and pass/password

once you log in you should be able to muddle your way through the portforwarding process or look on portforward.com for details


Share this post


Link to post
Share on other sites

Yea I went to portforward.com... And I found a link in a steampowered.com forum post... I followed the instructions, I entered all the port numbers and such in the 192.168.X.X ... And, I hit apply, it said something about 1 and 2... So I removed 2 because I don't think it was necessary, I hit apply, and it errased all except for 1... So idk. Anyways, gotta call a friend in Ohio, haven't called her in a while :whistle: Computers suck.


FootbaG

Share this post


Link to post
Share on other sites

yeah actually with cs:source i had very little luck with making a server behind a nat...

the dillema is that the cs server picks up on the LAN ip address and calls it a lan server

I couldnt find a way to force the server to take to your external ip


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0