Sign in to follow this  
Followers 0
SilverMiraida

RASDIAL endless loop

4 posts in this topic

This is my script

Run("rasdial ""net"" username password", @WorkingDir, @SW_HIDE)

The problem is, it keeps executing and shutting down endlessly, or if I write this RunWait instead of Run, it keeps executing endlessly without shutting down the instances of the program.

I don't know if this happens with this code only, or with others, because I've just got my new hard disk (the other broke), so the windows is new, everything is just installed, and it's my first script on this new windows (windows 7), I had this script before at startup, before my hard disk broke, and now I wanna recreate it so my new auto-connects at startup, without any window showing up.

Share this post


Link to post
Share on other sites



Hi, SilverMiraida, welcome to the forum. I haven't used Rasdial in a long time, but something like this should work for you (untested):

ShellExecute("rasdial.exe", '"net" "username" "password"', "")

√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Thank you for welcoming me kind sir.

I have used the following code with great success, thanks to you.

ShellExecute("rasdial.exe", '"connection name" "username" "password"', "", "", @SW_HIDE)

Share this post


Link to post
Share on other sites

Glad to be of service :)


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0