Jump to content
Sign in to follow this  
XuxinhaKill

Button doesn't work over an image

Recommended Posts

XuxinhaKill

Button works fine when doesnt have and image under it, when it has it doesnt work...

Can anyone tell me why and/or how to fix it?

#include <ButtonConstants.au3>
#include <EditConstants.au3>
#include <GUIConstantsEx.au3>
#include <StaticConstants.au3>
#include <WindowsConstants.au3>
#Region ### START Koda GUI section ### Form=
$Form1 = GUICreate("Form1", 469, 301, 287, 123)
$Pic1 = GUICtrlCreatePic(@ScriptDir & "\a.jpg", 0, 60, 468, 180)
$Iniciar = GUICtrlCreateButton("Iniciar (F8)", 155, 172, 75, 20, $BS_CENTER)
GUICtrlSetColor(-1, 0xFFFFFF)
GUICtrlSetBkColor(-1, 0x000000)
$Sair = GUICtrlCreateButton("Sair (ESC)", 238, 172, 75, 20, $BS_CENTER)
GUICtrlSetColor(-1, 0xFFFFFF)
GUICtrlSetBkColor(-1, 0x000000)
GUISetState(@SW_SHOW)
#EndRegion ### END Koda GUI section ###
While 1
$nMsg = GUIGetMsg()
Switch $nMsg
  Case $GUI_EVENT_CLOSE
   Exit
  Case $Sair
   Exit
  Case $Iniciar
   Exit
EndSwitch
WEnd

Share this post


Link to post
Share on other sites
BrewManNH

Stick to one thread please, it makes things a lot easier for everyone involved.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
XuxinhaKill

Stick to one thread please, it makes things a lot easier for everyone involved.

Yeah sorry, I realized I posted in the wrong session... then I duplicated it in the right session.

Share this post


Link to post
Share on other sites
zvvyt

Try adding the style $BS_FLAT to the pic, so it's "$Pic1 = GUICtrlCreatePic(@ScriptDir & "a.jpg", 0, 60, 468, 180,$BS_FLAT)".

Usually does the trick for me =)

Best regards,

zvvyt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×