Sign in to follow this  
Followers 0
Shanlar

Send("!{F1}") is only pressing F1

14 posts in this topic

Need it to do Alt+F1 but that doesnt seem to be happening. Only presses F1. I have also tried the following with no luck. Any insight if this problem would be helpful.

Send("{ALTDOWN}")
Send("{F1}")
Send("{ALTUP}")

Share this post


Link to post
Share on other sites



your going to have to do one send comand look at the help section under send or just give me a minute

Share this post


Link to post
Share on other sites

isnt it jsut

send("{!f1}")

'!'

This tells AutoIt to send an ALT keystroke, therefore Send("This is text!a") would send the keys "This is text" and then press "ALT+a".

Share this post


Link to post
Share on other sites

your going to have to do one send comand look at the help section under send or just give me a minute

<{POST_SNAPBACK}>

Yeah, as I probably should have restated from the topic, I tried Send("!{F1}) which should be ALT+F1, but it is only pressing F1.

Share this post


Link to post
Share on other sites

put the ! next to the f1

Share this post


Link to post
Share on other sites

put the ! next to the f1

<{POST_SNAPBACK}>

Send("{!F1}") is viewed as ! F1

{!} = !

While without {} ! = ALT

Share this post


Link to post
Share on other sites

my bad hahahah hey im a n00b and just putting stuff down

Share this post


Link to post
Share on other sites

just take out the brackets i looked on another thread and thats how he represneted it as

send("!f1")

Share this post


Link to post
Share on other sites

man the help section isnt helping this situation man im so bad at autoit

Share this post


Link to post
Share on other sites

Negative on the Send("!F1")

Share this post


Link to post
Share on other sites

i dont know why send("!{f1}") isnt working that should but maybe liek the help says its picky in ur title its upper case maybe it has to be lower case who knows except for alot of people on this forum

Share this post


Link to post
Share on other sites

the keys turn orange in scite if its good or not so thats the only thing way it turns orange :-/

Share this post


Link to post
Share on other sites

haha maybe send("{alt}""{f1}") :whistle: just throwing out random combos as i dance around the room to some music cuz im so bored

Share this post


Link to post
Share on other sites

Try

Send("!{F1}")

I tried it using F4 and it did as I was expecting



Get Beta versions Here Get latest SciTE editor Here AutoIt 1-2-3 by Valuater - A great starting point.

Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0