Jump to content
Sign in to follow this  
Hyflex

How do I convert HTTP Header Data to use Microsoft.XMLHTTP

Recommended Posts

Hyflex

Hey AutoIt Forums,

How do I use the http headers from below and turn them into sends for the microsoft.xmlhttp object.

Thanks in advance

- Hyflex

Username: admin

Password: admin

Login Post:

12:09:58.030 [285ms] [total 285ms]
Status: 200 [OK] 

POST http://192.168.1.1/index/login.cgi
Load Flags [LOAD_DOCUMENT_URI  LOAD_INITIAL_DOCUMENT_URI  ]
Content Size [560]
Mime Type [text/html]

Request Headers:
Host[192.168.1.1]
User-Agent [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0]
Accept [text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8]
Accept-Language [en-gb,en;q=0.5]
Accept-Encoding [gzip, deflate]
Connection [keep-alive]
Referer [http://192.168.1.1/]
Cookie [Username=YWRtaW4%3D; Password=YWRtaW4%3D; Saveword=1; Language=en; FirstMenu=Admin_0; SecondMenu=Admin_0_0; ThirdMenu=Admin_0_0_0]

Post Data:
Username [admin]
Password [YWRtaW4%3D]

Response Headers:
Set-Cookie [SessionID_R3=1897895720; path=/]
Date [Fri, 26 Oct 2012 11:09:58 GMT]
Connection [Keep-Alive]
Content-Type [text/html]
Cache-Control [no-cache]
Content-Length [560]

Disconnect Post:

12:11:16.573 [926ms] [total 926ms] 
Status: 200 [OK]
POST http://192.168.1.1/html/ntwkall/setcfg.cgi?x=InternetGatewayDevice.LANDevice.1&RequestFile=/html/ntwkall/wlan.asp
Load Flags [LOAD_DOCUMENT_URI  LOAD_INITIAL_DOCUMENT_URI  ]
Content Size[557]
Mime Type[text/html]


Request Headers:
Host [192.168.1.1]
User-Agent [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0]
Accept [text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8]
Accept-Language [en-gb,en;q=0.5]
Accept-Encoding [gzip, deflate]
Connection [keep-alive]
Referer [http://192.168.1.1/html/ntwkall/wlan.asp]
Cookie [Username=YWRtaW4%3D; Password=YWRtaW4%3D; Saveword=1; Language=en; FirstMenu=Admin_1; SecondMenu=Admin_1_2; ThirdMenu=Admin_1_2_0; SessionID_R3=1897895720; lastpage=http%3A%2F%2F192.168.1.1%2Fhtml%2Fwizard%2Fsumgeneral.asp]

Post Data:
x.X_WLANEnable[0]

Response Headers:
Date [Fri, 26 Oct 2012 11:11:17 GMT]
Connection [Keep-Alive]
Content-Type [text/html]
Cache-Control [no-cache]
Content-Length [557]

Connect Post:

12:12:31.640 [2206ms] [total 2206ms]
Status: 200 [OK]

POST http://192.168.1.1/html/ntwkall/setcfg.cgi?x=InternetGatewayDevice.LANDevice.1&RequestFile=/html/ntwkall/wlan.asp
Load Flags [LOAD_DOCUMENT_URI  LOAD_INITIAL_DOCUMENT_URI  ]
Content Size [557] 
Mime Type [text/html]

Request Headers:
Host [192.168.1.1]
User-Agent [Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0]
Accept [text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8]
Accept-Language [en-gb,en;q=0.5]
Accept-Encoding [gzip, deflate]
Connection [keep-alive]
Referer [http://192.168.1.1/html/ntwkall/wlan.asp]
Cookie [Username=YWRtaW4%3D; Password=YWRtaW4%3D; Saveword=1; Language=en; FirstMenu=Admin_1; SecondMenu=Admin_1_2; ThirdMenu=Admin_1_2_0; SessionID_R3=1897895720; lastpage=http%3A%2F%2F192.168.1.1%2Fhtml%2Fwizard%2Fsumgeneral.asp]

Post Data:
x.X_WLANEnable [1]

Response Headers:
Date [Fri, 26 Oct 2012 11:12:33 GMT]
Connection [Keep-Alive]
Content-Type [text/html]
Cache-Control [no-cache]
Content-Length [557]
Edited by Hyflex

Share this post


Link to post
Share on other sites
Hyflex

No one know how?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×